Help with network scanner access on 20.08


I’m trying to replace our unsupported openvas installation with a new 20.08 one on Ubuntu. I’ve followed the excellent guide here:

All works without a hitch to run the scans through the web, but we automate ours from a remote machine and I cannot get the new version working correctly. I’ve updated the PostgreSQL to make that available on the network but I cannot seem to get GVMD working as it break the web interface.

If I update the file /etc/systemd/system/gvmd.service with the following line:

ExecStart=/opt/gvm/sbin/gvmd --osp-vt-update=/opt/gvm/var/run/ospd.sock --port 9390 --a=

gvmd no longer listens on ‘/opt/gvm/var/run/gvmd.sock’ so the automation should work, but the web interface breaks and if I run with ‘gvmd -c /opt/gvm/var/run/gvmd.sock --port 9390 --a=’ I get an error suggesting that it cannot listen on both a socket and IP at the same time.

I suspect that I need to run with ‘–port 9390 --a=’ and adjust GSA to use the address and port instead of the unix socket (I hope my description is right as I’m not that familiar with Unix!).

Can anyone help advise how to get the network port listening without breaking the web interface?


You can tell gsad (the web interface) to connect to the manager (gvmd) via the following two command line options:

  --mlisten=<address>                    Manager address.
  -m, --mport=<number>                   Use manager port number <number>.
1 Like

That worked, thanks. I had to remove ’ --drop-privileges=gvm’ for it to work.

The final changes if it’s useful to anyone were:

sudo nano /etc/systemd/system/gvmd.service
ExecStart=/opt/gvm/sbin/gvmd --osp-vt-update=/opt/gvm/var/run/ospd.sock --port=9390 -a

sudo nano /etc/systemd/system/gsad.service
ExecStart=/opt/gvm/sbin/gsad --mlisten=SERVERIP --mport=9390