GVM scripts

Hello All,
I used the below command to download pdf file
gvm-script --gmp-username user --gmp-password pass socket --hostname gsm scripts/pdf-report.gmp.py 5057e5cc-b825-11e4-9d0e-28d24461215b myreport

I am unable to figure out the parameter “gsm” ???
if i remove “gsm” from the command it says “Script pass does not exist”.
Can anyone help me?

First of all please always add the version of the software you are using to the description of your issue. You may encounter issues already fixed in newer versions. Without detailed information most likely nobody is able to help you.

Second --hostname is not a valid parameter for the socket connection type. The socket connection type allows only local connections via a unix domain socket to connect to the running gvmd.

Sorry for making it a fuss.
I’m working on a centos7 server and I installed the gvm-tool 2.1.0 after finding out that i was working on 1.4.1 version
I ran this command now gvm-script --gmp-username user --gmp-password pass socket listtask.py
it returned [Errno 13] Permission denied
when I used it with sudo it says gvm-tools doesn’t exist.
I used poetry to install gvm-tools 2.1.0
As my gvmd and gsad is running as root, I tried to make them run as non-root user but failed to do so.
gvmd --listen-group=user --listen-owner=user