Gvm does not find the vulnerabilities

Good morning everyone, i updated my kali to version 2022.3 i tried to do a scan with gvm , after completing it returns me zero vulnerabilities, i updated the feeds but nevertheless it can’t find the cve. the check returns me very good results:
gvm-check-setup 21.4.3
Checking for completeness and availability of GVM-21.4.3
Step 1: Verification of OpenVAS (Scanner)…
OK: OpenVAS Scanner is present in version 21.4.4.
OK: The server CA certificate is present as /var/lib/gvm/CA/servercert.pem.
Checking the permissions of /var/lib/openvas/gnupg/*.
OK: _gvm owns all the files in /var/lib/openvas/gnupg
OK: redis-server is present.
OK: the scanner (db_address setting) is configured correctly using the redis-server socket: /var/run/redis-openvas/redis-server.sock
OK: redis-server is running and listening on socket: /var/run/redis-openvas/redis-server.sock.
OK: redis-server configuration is correct and redis-server is running.
OK: _gvm has all the files in /var/lib/openvas/plugins.
OK: The collection of NVTs in /var/lib/openvas/plugins contains 104908 NVTs.
Checking for removal of obsolete redis database
OK: No old redis database
OK: ospd-OpenVAS is present in version 21.4.4.
Step 2: Checking GVMD Manager …
OK: GVM Manager (gvmd) is present in version 21.4.5.
Step 3: Checking certificates …
OK: GVM client certificate is valid and present as /var/lib/gvm/CA/clientcert.pem.
OK: The GVM certificate infrastructure has passed validation.
Step 4: Data verification …
OK: SCAP data found in /var/lib/gvm/scap-data.
OK: CERT data found in /var/lib/gvm/cert-data.
Step 5: Verification of Postgresql DB and user …
OK: Postgresql version and default port are correct.
gvmd | _gvm | UTF8 | en_IT.UTF-8 | en_IT.UTF-8 |
OK: At least one user exists.
Step 6: Checking Greenbone Security Assistant (GSA) …
Oops, secure memory pool already initialized
OK: Greenbone Security Assistant is present in version 21.4.4.
Step 7: Checking for active and running GVM services …
Starting the ospd-openvas service
Pending ospd-openvas service
OK: The ospd-openvas service is active.
Starting the gvmd service
Waiting for the gvmd service
OK: the gvmd service is active.
Starting the gsad service
Waiting for gsad service
OK: gsad service is active.
Step 8: Checking for other requirements…
OK: nmap is present in version 21.4.4.
OK: found ssh-keygen, LSC credential generation for GNU/Linux targets is likely working.
WARNING: unable to find makensis binary, LSC credential packet generation for Microsoft Windows targets will not work.
TIP: install nsis.
OK: SELinux is disabled.
OK: found xsltproc.
WARNING: the password policy is empty.
TIP: edit the /etc/gvm/pwpolicy.conf file to set a password policy.

It appears that the installation of GVM-21.4.3 is correct.

How can I do to fix the problem?
thanks in advance

Translated with DeepL Translate: The world's most accurate translator (free version)

@caio82 well. you need provide some evidences like logs, error and so on…

need the log and then ??

@caio82 You need to provided errors (screenshot, log entries ) and so on. I cannot see any errors…


This could help as well:

Hello everyone, in the end I uninstalled and reinstalled, updated all feeds, now it works, scans and finds vulnerabilities, the point is that it generates me a pdf report of 0 bytes. What could it be??

This problem is already known, please refer to this thread to get more information about it.


I sometimes run into this phenomenon, but this is caused by the update process.
Just have a look at the web console Administration/Feed Status. As long as I see “Updating” there is no result in the scanning