GVM 20.08 on Ubuntu 18.04 LTS

Hello Everyone,

I’m starting this topic because I’m stuck in the installation of my OpenVAS. I used the link mentionned below in my “Environment” section, I can’t install the OpenVAS Scanner because of a missing GnuTLS correct version to use, the problem is I can’t use an Ubuntu 20.04 LTS actually, but a 18.04 LTS and I need to install OpenVAS soon.
I already tried to install the correct version using the website Linux From Scratch, but it doesn’t work, GnuTLS needed Nettle, installed with the same method (Linux From Scratch), but can’t be recognized when I tried to compile GnuTLS (Error : “Libnettle 3.6 was not found.”).

Is there any version that I can use for an Ubuntu 18.04? Or any solution to have GVM20.04 on 18.04 LTS?

Thanks a lot for your answers in advance …


Operating system: Hardened Ubuntu 18.04 LTS
Kernel: Linux ******** 4.15.0-129-generic #132-Ubuntu SMP Thu Dec 10 14:02:26 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Installation method / source: Source (Used this tutorial : https://www.libellux.com/openvas/#configuration-files)

Hello Romain,

I had the same problem, so I installed nettle-3.6 and gnutls-3.6.15 in /opt/gvm directory tree, aside of libgnutls-3.5.18 shipped with Ubuntun 18.04

Once you’ve done that and run ldconfig, you can compile GVM 20.08 as it will pickup the gnutls libraries in /opt/gvm/lib first.

This is a hack obviously, as it’s better not to mix different libs version on the same system, but I don’t think there is any other solution unless migrating to Ubuntu 20.04.


1 Like

Thanks for your help, unfortunately, it didn’t work for me, GnuTLS still requires Libnettle3.6, while Nettle 3.6 is properly installed in the same directory (/opt/gvm), to be installed from scratch…

Many users have tried successfully to Install GVM-20.08 on Ubuntu Server 20.04 using this tutorial:

It is in German, but you can use the translator on the website:

1 Like

What options do you pass to cmake when building gnutls ? There is no reason it shouldn’t work unless it doesn’t find your nettle libraries at built time.

1 Like

In my case I used those 2 links :

And changed the Prefix in the “make” command to match with the directory of gvm (/opt/gvm)

1 Like

If you are able to use docker on your 18.04, then you may have good results with:


Currently running 20.08 with postgres12
no building necessary.