GSM Trial on Virtual Box Doesn't Work or missing components

I have gone through this process to install the GSM Trial on virtual box.

After that is installed, the feed updates, at least reportedly it does, I can’t do any scans. The web interface complains about it needing an SCAP database. Don’t see this documented anywhere.

I can’t do a scan because it doesn’t have a config and I can’t find anything useful anywhere to resolve this.

So what is missing from the official documentation to get the GSM trial to be useable? I used to have the old community edition working just fine but since that feed seems to be completely shutdown, I need to switch to this version but so far it doesn’t actually appear to be an available option.

Has anybody gotten the new trail version working? How?

Hi, with 20.08 the scan configs are synced with the feed. In your case the feed hasn’t synced yet and therefore the scan configs aren’t available. Please wait until the complete feed has been downloaded and loaded by the software components.


I had invoked a feed update multiple times and waited for the process to finish. The feed status page in the web console also continually toggled from current to update in progress. When I started up the VM today, all the NVT’s and such showed populated, which they did not the previous day. Once an update started, all those NVT’s disappeared and the system continually crashed.

In an attempt at a clean slate, I tried to just start over and re-install and I remember having issues the first time around on installing but this time…something in this process is very unstable.

Attempt 1:
The setup got stuck in a loop of switching from Installation in progress to dumping some sort of stack trace that looks like a crash report.

Attempt 2:
I attempted another install and this time it didn’t get stuck in a loop but did dump the stack once and then finished but then after it finished and you select reboot, it dumped to the console and never actually rebooted. I killed the VM and restarted which seemed to move along but after going through all the basic setup again I can’t reach the web interface so it likely failed to install properly.

Attempt 3:
Same as attempt 2 with the single crash dump but then proceeded without issue through the install, got to the reboot option, rebooted and then failed to initialize something during this process and so never completed the second restart.

I then logged in and went to the reboot option and then this process finished successfully and rebooted again.

Went through the setup and waited for the feed process to finish. I can see the NVT’s, SCAP’s etc. Checked the feed status in the web and waited for Update in progress to complete but it still shows the missing database. It seems to be stuck in another loop where as soon as it finishes the update it immediately tries to update again.

So after new install, the feed updates as far as I can tell from the terminal interface, the web UI toggles between current and updating but still no configs. The VM has been running for probably an hour at this point so not sure how long this is supposed to take but that seems like more than enough time. The scan configs just show one entry on the web ui, empty. Where do I go from here?

Anybody that’s successfully ran the GSM trial image on virtual box have any ideas? I would have assumed a virtual installation with a pre-canned image would more stable than what I’m experiencing.

It works without any issues here, i guess either your host or virtual box is not correct. Please follow the individual steps. Alternatively you can might try VMWare-Player. It is important that your system is connected to the internet and not sharing the connection with other GVM installations.

1 Like

I have followed those steps exactly multiple times and I have setup many VM’s with access to the internet without issue so I know that’s not the problem. I also have all other VM’s shutdown during these tests just to be safe so there’s no sharing of any kind happening there. The fact that the install itself seems very unstable, as shown in my earlier post, as well as once it is installed, it just doesn’t seem to get a good configuration. If I had no access to the internet, I’d never have a feed updated to current and showing NVT’s right?

Troubleshooting tips? Command line options to check install? Failure logs? There’s something more going on here than just no internet but all I know is installing it in a VM as per the instructions, however many times that takes to not fail, does not work once successful.

I assume the installation issue is the root cause of your problems. We are unable to reproduce the installation issue on our side however. Which hypervisor, including the exact version, are you using?

In the meantime, we are also working on a new delivery method for the GSM TRIAL that will skip most of the installation process, so you can get started faster and easier. I don’t have an ETA for you right now, but it should be up soon.