Gsad can't connect to gvmd

GVM versions

gsad: Greenbone Security Assistant 20.8.1
gvmd: Greenbone Vulnerability Manager 20.08.3~git-5b83b66a-gvmd-20.08
openvas-scanner: OpenVAS 20.8.3


Operating system:
Kernel: Debian 4.19.194-2
Installation method / source: from source


I have a problem with OpenVAS, I can’t connect to the GUI, I have the following error:

The Greenbone Vulnerability Manager service is not responding. This could be due to system maintenance. Please try again later, check the system status, or contact your system administrator.

When I look in the logs, I get this error :

gsad main:WARNING:2021-07-22 07h38.20 utc:494: MHD: Error: received handshake message out of context
gsad gmp:WARNING:2021-07-22 07h38.20 utc:494: Failed to connect to server at /run/gvm/gvmd.sock: No such file or directory
gsad gmp:WARNING:2021-07-22 07h38.20 utc:494: Authentication failure for ‘admin’ from ... Status was 1.

I don’t understand, no matter what I do, I get this error. The socket does not exist in this directory, but in the /opt/gvm/var/run and it is well informed in the different configuration files.

any idea where the error comes from?

gsad tries to connect to gvmd via /run/gvm/gvmd.sock and as you stated it is in /opt/gvm/var/run/gvm/gvmd.sock. You need to adjust the cmake build parameters to change the path or just start gsad (or gvmd) with different parameters to use the same unix socket. See gsad --help or gvmd --help.

Additionally you should follow when building from source.

Thx for the answere !
Here is what I did :

gvmd --unix-socket=/opt/gvm/var/run/gvm/gvmd.sock
gsad --unix-socket=/opt/gvm/var/run/gvm/gvmd.sock

I get this message when I make the modification with gsad :
Oops, secure memory pool already initialized

I still have nothing working, with the same error in the logs.

Could you please take a second look at gsad --help and choose the correct parameter --munix-socket=<file> Path to Manager unix socket instead.