GSA Source Download 404


I’m attempting to build the GVM stack from source (Building GVM 21.04 — Greenbone Documentation documentation) and I’ve got down to to downloading the GSA sources but it’s returning a 404 when trying to access:$GSA_VERSION.tar.gz

Can someone let me know if the file’s been moved and/or point me in the right direction.



**Operating system:Linux
**Kernel: Debian 5.10.84-1
**Installation method / source: Building GVM 21.04 guide

Hi @DaveAngel and welcome to the forum :slight_smile:

I’m able to download it fine. Did you first set the version to download? example: export GVMD_VERSION=21.4.4


Hi DeeAnn,

Thanks :grinning:

I’d done that for GMVD and that worked fine - in the instructions it says to set the version by “export GSA_VERSION=$GVM_VERSION” which gives me the 404 so i tried manually changing to GSA_VERSION=21.4.4 which gave the same result but GSA_VERSION=21.4.3 worked!

Managed to verify the source files but then when i try to extract the tarballs i get this:

tar: You must specify one of the ‘Acdtrux’, ‘–delete’ or ‘–test-label’ options

Any ideas?


1 Like

You’re welcome! :slight_smile:

Yep, there are several modules and they may have different version numbers, and via export you’re telling it what version to get and when in the process, so if any one of those gets missed it’ll look for something that isn’t there (or possibly grab the wrong thing).

Question- are you typing in the tar command? If so watch for “u” and “v”.

1 Like

Thanks again - i’m not sure exactly what my issue was but I ended up starting again and got right the way through then ended up at the giving the gvm user permission to the /run/gvm folder only to find it didn’t exist… will try again in the new year :slight_smile: