Greenbone SSL setup

Hello, I have been trying to configure greenbone community edition within docker for the past few days. I have created self signed certificates, and have their location denoted in my docker-compose.override.yml file. The other docker-compose file is unmodified, and for testing purposes I have set the folder that the certificates as rwx for everyone. Now, after I start the greenbone containers the gsad has the following output.
Failed to open file “/var/lib/gvm/private/CA/serverkey.pem”: No such file or directory
The directory that is referenced in the error log is nowhere in either of my config files, and I have tried force recreating, building without cache, and completely deleting and pulling the images. If I run just the base docker-compose file everything works through http. Though, if I change the config of the main docker compose file or the override file it is unreachable through https and the error is thrown again. The following is the override file:

Even more interestingly, inspecting the gsa container shows that the set values for the certificate location is inside of the configuration meaning that it should be applied yet it still throws the error.
Nowhere within the output of the inspect does it display the path /var/lib/gvm/private/CA/serverkey.pem (Shown in error message). I am at the end of my experience for troubleshooting this further, and any help would be appreciated.

Greenbone Version: 22.04
Docker version 20.10.21

I’ve been struggling myself trying to setup SSL.

What worked for me finally was leaving the original paths in the gsa block of the docker-compose.yml, like this:

    image: greenbone/gsa:stable
      - GSAD_ARGS=--no-redirect
    restart: on-failure
      - 9392:443
      - gvmd_socket_vol:/run/gvmd
      - source: server-certificate
        target: /var/lib/gvm/CA/servercert.pem
      - source: private-key
        target: /var/lib/gvm/private/CA/serverkey.pem
      - gvmd

Then at the end of the docker-compose.yml file place this block:

    file: /REAL/PATH/TO/YOUR/CERT/servercert.pem
    file: /REAL/PATH/TO/YOUR/KEY/serverkey.pem

I don’t know why but placing your path into the gsa block seems to not work.