Greenbone GVMD_DATA too old (74 days) after sync


I currently have the problem, that my GVMD_DATA feed is not updating, which leads to unreviewable reports, because they all become labeled as “HIGH”.

I have already run the following commands (waiting for the “Update in progress…” message to go away after every command). I ran all of the syncs as gvm user.

greenbone-feed-sync --type SCAP
greenbone-feed-sync --type CERT
greenbone-feed-sync --type GVMD_DATA
sudo openvas --update-vt-info

GVM versions

gsad: 21.04.0~git-2cffc292b-HEAD
gvmd: 21.4.0~git-d8d82b405-HEAD
openvas-scanner: 21.4.0~git-4f11a5e3-HEAD


Operating system: Debian 10.10
Kernel: Linux b06x-gb 4.19.0-17-amd64 #1 SMP Debian 4.19.194-2 (2021-06-21) x86_64 GNU/Linux
Installation method / source: Installation from source

Thanks for any help in advance

Hello and welcome to this community forum.

Those are two different topics which have a different origin:

  1. The GVMD_DATA too old is something which can / needs to be ignored (see GVMD_DATA - Too old (34 days) Please check the automatic synchronization of your system - #24 by bricks) and doesn’t cause the “HIGH” labeled results
  2. The “HIGH” labeled results are originating from using outdated components of GVM (openvas-scanner: 21.4.0~git-4f11a5e3-HEAD) and can be solved by updating all GVM components to the latest available 21.4.4 announced in GVM Release Version 21.4.4

Hi, here an script to update gvm:


set -u
set -e

sudo runuser -u _gvm -- greenbone-nvt-sync

sleep 10

sudo -u _gvm greenbone-feed-sync --type GVMD_DATA

sleep 10

sudo -u _gvm greenbone-feed-sync --type SCAP

sleep 10

sudo -u _gvm greenbone-feed-sync --type CERT

sleep 10

sudo openvas --update-vt-info

exit 0

hello, as far as I remember @bricks
says that the command “sudo openvas --update-vt-info” is not recommended to be run by yourself and that this is not correct

There is an issue with your script:
[sudo] password for admin:
Sorry, user admin is not allowed to execute ‘/sbin/runuser -u _gvm – greenbone-nvt-sync’ as root on

Hi there,

I have a similar issue.
already tried:
sudo /usr/sbin/greenbone-feed-sync --type GVMD_DATA
I can see is trying to update

but in the end, still shows “Too old (79 days)”.

Q1: How do I know what is the latest GVMd?
Q2: If the 20220128T1556 is not the latest how do I update to the latest one?

I’m using GSM trial virtual appliance.
Greenbone OS 21.04.15
Linux gsm 4.19.0-19-amd64 #1 SMP Debian 4.19.232-1 (2022-03-07) x86_64 GNU/Linux

Thank you and best regards,

Hi, this script is working fine on kali linux 2022.1.

In your case it seem’s a read/write permission issue, see here

Please note that postings from the Greenbone Source Edition (GSE) category, especially if they are involving command line scripts / commands are in most cases not applicable for the GSM based installations which you seems to run.

Please use the GOS menu to sync the feeds instead.