Greenbone 21.4.3 remote control

hello everyone,

I installed Greenbone Security Assistant version 21.4.3 on my kali device.

I want to send commands to this device with gvm-cli from my windows device, but I can’t get a response.

the code i tried;
gvm-cli tls --hostname --port 9390 GMP_USERNAME=admin -X “<get_version/>”

Can you help with the problem? Do I need to enable anything for gvm-cli to work? mean localhost. You need to enable listen to network and then send commands to right port or run commands over ssh (putty)


how can i enable listen to network ?

You need to create certificates and change gvmd to use TLS instead of just listening on a unix domain socket.

change your service unit file or start script and add --listen= --port=9390 for gvmd. Once you have done you should be able to use your windows system together with gvm-cli to connect to the service.

hello again,

I applied what you said and got successful results.
<get_version_response status=“200” status_text=“OK”>21.4</get_version_response>

but now greenbone is currently running on port 443. When I want to login, I get the following error.

The Greenbone Vulnerability Manager service is not responding. This could be due to system maintenance. Please try again later, check the system status, or contact your system administrator.

can you help me ?

AFAIK you need to tell the gsad daemon on startup (e.g. in your systemd startup file) via the following parameter that it should now connect to the port:

  -m, --mport=<number>                   Use manager port number <number>.