First scan "invalid date"

Hi, Day One Newbie here (followed the incredible instructions by koromicha and set one up yesterday.)

Tried my first scan, but it failed after about 30 seconds. When I opened the Task, it says “Duration of last Scan” with “Invalid Date”.

I saw in github there’s a ticket (#1405) that addressed the issue, but I still see it…don’t know if they are related.

Any suggestions/assistance is greatly appreciated!

I spun up another instance, this time via the virtual appliance (gsm-ce-6.0.7.iso), same result… :frowning:

Please note GCE always run in UTC, check that your hypervisor has a correct date, and change it to UTC. Then you can set your User_Settings to your local time zone.

Hi. I’ve tried this twice…Once through the installation instruction from koromicha and deployed that in my company’s ESXi infrastructure.

The second try was on my local computer.

Both infrastructures has the correct local time…however, I can’t set either to “UTC” timezone, as ESXi and Windows 10 got their time via NTP.

I DID, change User_Settings to “America/Los_Angeles” and ran the task again…didn’t work/help…

Please note, you need to run your hypervisor in UTC, otherwise Multi-User and Scan´s across different time zones do not work.

So please set your hypervisor to UTC, ntp is timezone agnostic, and always in UTC :wink: So your host setup needs to be fixed.

Lukas, thanks for the reply. I guess our ESXi servers ARE running in UTC (as a matter of fact, all ESXi servers are running in UTC, according to the article.)

I have also confirmed that the time shown is in UTC (…but scan still failed (

Please delete all tasks and create a new one … You have to set your time zone withing user settings.

I did…I deleted everything in Targets and Tasks, make sure My settings has the correct Timezone, then re-created one Task with one Target…sorry, still returned “Invalid date.”

same problem here - hypervisor running in UTC, no matter what timezone I configure in the VM or in greenbone web-ui I always get “invalid date”

Can you share us a example tasks, saying invalid date … did you tried the tasks in UTC ?

Host/hypervisor is running in UTC, VM also in UTC, greenbone user “gvmadmin” is configured to use UTC, task was created when everything was UTC. The file is here:

I tried another hypervisor, libvirt/KVM, with the same error. The config was <clock offset='utc'> <timer name='rtc' tickpolicy='catchup'/> <timer name='pit' tickpolicy='delay'/> <timer name='hpet' present='yes'/> </clock>, also with hpet absent.
Hypervisor before was FreeBSD/bhyve with the -u flag.

gave it another try with the official iso: still the same error.

after having the vm run for several hours and tinkering around with timezone and the web ui: the behaviour concerning the “invalid date” is not really reproducible. I managed to launch some scans, however, and that is weird: I created them the same way for 5 hosts: two scans were ok, but three aborted with “invalid date”.

That ISO is only supported on Virtual Box and VMWare-Player, can you re-check please …