First scan failed


Yesterday I downloaded and installed the newest GSM-VM (gsm-ce-6.0.0.iso).
on my service notebook. I run this VM under virtualbox 6.0.14 with NAT-Network.
I can access the GUI via WEB-If und ping my destination hosts from VM.
Job for feed update seems also tu be sucessful.
But when I try to do my first scan nothing is found.
Neither the own vm host ist found nor other hosts, which are pingable.

I can’t find any help online. Are there a logfiles ?
What could be wrong ?



Did you already read following topics? Maybe one of these is already solving your problem?

Please also try to provide as much information as possible, e.g.:

  • What feed version are you using?
  • Which scan configuration do you use?



I had a look to the mentioned topics, but I think this is not my problem.
I got the following error: “Could not connect to Scanner” in the report.
I also reinstalled the VM, but nothing changes.

Same error “Could not connect to Scanner” , hoping for a solution. Thank You

Hi, what happens when you run the VM in “Bridged” mode (if that is an option)?

How much memory did you assign to the VM, how many cores ? This happens if your Scanner is no longer running or not ready yet.


I run it on a notebook VM under virtualbox with 4GB RAM and 18GB disk.
I reinstalled it on a more performat machine als virtualbox VM with NAT-Network,
6GB RAM, 18GB Disk an 2 CPU’s.
And now it’s working.

Did you checked the logs, if the scanner is still active ?

What is the scanner binary (to look for in ps output) and how do I run it if it is not active?
What is the log file you are referencing?
I can ssh into the VM but my admin user doesn’t have sudo priviledges so I can’t even open the files in /var/log.

I think the problem is that you have to wait after starting the VM and logging in, for the scanner to be ready. It’s not obvious because my feeds show as current. I found the Scanners here:


After confirming that they are listed, my scan worked. All I did was wait.


For me it is not the case. I have all scanners listed but the same problem.

Please help me,


You should try to reboot the GSM a couple of times. My installation somehow did not successfully finish the installation wizard and after reboot it asked: “You’re installation is not complete…” or sth like that.

Eventually it passed the installation and then my scanners had no problems anymore.

1 Like

A post was merged into an existing topic: Severity error. Could not connect to server