Failed to rebuild gvmd data

Finally I’ve made it to almost working Greenbone on Debian (via manual), to a point:

  • No port lists available
  • No Scan Configs available

Tried following:

  • purged the content of /var/lib/gvm and resynced all - NVTs, SCAP, CERT, GVMD_DATA, no succeed
  • followed the troubleshooting in the manual:
    $ find /var/lib/gvm/data-objects/ -name “33d0cd82-57c6-11e1-8ed1-406186ea4fc5.xml”

$ sudo -u gvm greenbone-feed-sync --type GVMD_DATA

$ sudo -u gvm gvmd --rebuild-gvmd-data=all
Failed to rebuild gvmd data: Feed owner not set or invalid while rebuilding configs.

The same message appears in /var/log/gvm/gvmd.log

Any hints?


the error message suggest that the feed import owner is not set. See the bottom of the section to set the feed import owner.


It’s working. I had to split the command:

gvmd --modify-setting 78eceaec-3385-11ea-b237-28d24461215b --value `gvmd --get-users --verbose | grep admin | awk '{print $2}'

into two because the quotations of value parameter were causing issues (gvmd: g_option_context_parse: Missing argument for --value):

sudo -u gvm gvmd --get-users --verbose | grep admin | awk '{print $2}'
sudo -u gvm gvmd --modify-setting 78eceaec-3385-11ea-b237-28d24461215b --value 99d19126-0e8c-412d-b3f9-48c8ea0c648f

my fault, i haven’t understood the message properly previously. could save the post here. hope the others will take it.


Finally. This worked out for me. @bricks , could the docs be edited to split the command? It’s kind of confusing for beginners.

Could you please explain what’s confusing here? I don’t see an issue with the command.