Failed to find config

GVM versions

gvmd: 20.08.0
openvas-scanner: 20.8.0
gvm-libs: 20.8.0


Operating system: ubuntu:20.04 image inside docker
Kernel: 5.4
Installation method / source: from source (

Hello guys,
I am facing a problem regarding the scan configs. Other commands like creating a target work.

Every time I create a task with a given config_id (for example daba56c8-73ec-11df-a475-002264764cea, but I also tried with other IDs) a 404 error is returned with the status_text=“Failed to find config ‘daba56c8-73ec-11df-a475-002264764cea’”. The configs are present in my system (/usr/local/var/lib/gvm/data-objects/gvmd/20.08/configs/), among port_lists and so on.

I have looked on previous post and I tried everything that was mentioned, but the problem still persists. I tried to look into my postgres db and the port_lists are populated, but the configs table is empty.

The redis.sock has enough permissions, the right path, ospd.sock has enough permissions, is in the right path and the ospd connects to him, gvmd.log doesn’t show anything strange.

Here you can find the config files that I’ve used:

Any ideas?

Thank you,

It might be possible that you have a bug in your script causing this issue. In that script ospd-openvas is configured here:

ospd-openvas --log-file /usr/local/var/log/gvm/ospd-openvas.log --unix-socket /var/run/ospd/ospd.sock --log-level DEBUG

to listen on /var/run/ospd/ospd.sock but here:

su -c "gvmd --osp-vt-update=/opt/gvm/var/run/ospd.sock" gvm

you’re telling gvmd to connect / use /opt/gvm/var/run/ospd.sock.

I’m not familiar with gvmd, how/if there should be some logging about that and if anything additional is required after correcting this. But it definitely worth to check what happens if you’re configuring the socket correctly. According to gvmd --help you could drop the complete --ospd-vt-update line as it will use the socket /var/run/ospd/ospd.sock by default:

--osp-vt-update=<scanner-socket>              Unix socket for OSP NVT update.  Defaults to the path of the'OpenVAS Default' scanner if it is an absolute path.

If you decide to change the /var/run/ospd/ospd.sock make sure to read this:

Thank you cfi for your time. Your comment makes sense and I’ve updated my setup, but the problem still persists. I have updated the gist accordingly. I think the problem is in the database area because the xml config files are present on the system, but the postgres db is not populated. Any ideas?

Quick update: after I updated the setup, the NVTs and the configs were added after some minutes to the database and the problem seems to be gone. I will come back after some more thorough testing.

1 Like

All right, after some more testing it seems to work as expected. Thank you @cfi for your time.

1 Like