Fail to start gvmd service

I follow this guide Building 22.4 from Source - Greenbone Community Documentation to install into Ubuntu 22.04.

But during the process the command to start the gvmd service failed with the below error

Aug 12 08:13:11 openvas systemd[1]: gvmd.service: Can’t open PID file /run/gvmd/ (yet?) after start: Operation not permitted
Aug 12 08:14:41 openvas systemd[1]: gvmd.service: start operation timed out. Terminating.
Aug 12 08:14:41 openvas systemd[1]: gvmd.service: Failed with result ‘timeout’.

My service file has the below content
Description=Greenbone Vulnerability Manager daemon (gvmd) networking.service postgresql.service ospd-openvas.service
Wants=postgresql.service ospd-openvas.service

ExecStart=/usr/local/sbin/gvmd --osp-vt-update=/run/ospd/ospd-openvas.sock --listen-group=gvm


Kindly, help me to fix this

@jozb sounds like a permission problem on directories. try again.


@Eero what the can I do with it? tell me the right permission to put

@jozb sorry, there are multiple steps in instructions. try to follow all step by step.


@Eero , As I said, I follow all the steps, and that is where I gat the error. Please help me

If the gvmd service doesn’t start the logfile of it (should be at /var/log/gvm/gvmd.log) should give some hints why it doesn’t start up.

@cfi , thanks for the insight… I tried to check this… see the below error on the log file.

md manage:WARNING:2022-08-12 06h22.34 utc:3332: sql_exec_internal: SQL: SELECT value FROM public.meta WHERE name = ‘database_version’;
md manage:WARNING:2022-08-12 06h22.34 utc:3332: sql_x: sql_exec_internal failed
md manage:MESSAGE:2022-08-12 06h22.34 utc:3332: No SCAP database found
md manage:MESSAGE:2022-08-12 06h22.34 utc:3332: No CERT database found
md manage:MESSAGE:2022-08-12 06h22.34 utc:3332: db_extension_available: Extension ‘pg-gvm’ is not available.
md manage:WARNING:2022-08-12 06h22.34 utc:3332: check_db_extensions: A required extension is not available.
md manage:WARNING:2022-08-12 06h22.34 utc:3332: init_manage_create_functions: failed to create functions

Can you help me on this friend?

Looks like there are indeed some steps missing from the documentation as pointed out by @Eero previously or there is a build issue in that step around pg-gvm:

Let me rebuild it again. I will update on this

@cfi @Eero I managed to start afresh and the services is running… But how can I access it to my browser? I deploy it to my server with an IP of 10.200.x.x

I tried to use http://10.200.x.x:9392 but it’s not loading the page

@jozb just check with netstat -tupln for listening ports.

Is there nat or fw device present on network? is it virtual box?


As the problem of the not starting gvmd service has been solved please mark this topic as solved and create a new topic for this new problem / question.

1 Like

Yes, Its vm server. I check the ports

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0* LISTEN 17120/postgres
tcp 0 0* LISTEN 16117/redis-server
tcp 0 0* LISTEN 804/systemd-resolve
tcp 0 0* LISTEN 18347/gsad
tcp 0 0* LISTEN 16524/mosquitto
tcp 0 0* LISTEN 862/sshd: /usr/sbin
tcp6 0 0 ::1:1883 :::* LISTEN 16524/mosquitto
tcp6 0 0 :::22 :::* LISTEN 862/sshd: /usr/sbin
tcp6 0 0 ::1:6379 :::* LISTEN 16117/redis-server
udp 0 0* 804/systemd-resolve

@jozb its really hard to say anything without network diagram. you probably need port forward

The discussion for the listening address is moved to How to access the the platform through web browser

1 Like