ERROR: No users found. You need to create at least one user to log in

Hello everyone

I allow myself to create this post after several attempts to install and search on the internet

Each time I install OpenVas I always get the same error:

$ sudo gvm-check-setup                        
gvm-check-setup 21.4.2
  Test completeness and readiness of GVM-21.4.2
Step 1: Checking OpenVAS (Scanner)... 
        OK: OpenVAS Scanner is present in version 21.4.2.
        OK: Server CA Certificate is present as /var/lib/gvm/CA/servercert.pem.
Checking permissions of /var/lib/openvas/gnupg/*
        OK: _gvm owns all files in /var/lib/openvas/gnupg
        OK: redis-server is present.
        OK: scanner (db_address setting) is configured properly using the redis-server socket: /var/run/redis-openvas/redis-server.sock
        OK: redis-server is running and listening on socket: /var/run/redis-openvas/redis-server.sock.
        OK: redis-server configuration is OK and redis-server is running.
        OK: _gvm owns all files in /var/lib/openvas/plugins
        OK: NVT collection in /var/lib/openvas/plugins contains 77554 NVTs.
Checking that the obsolete redis database has been removed
        OK: No old Redis DB
        OK: ospd-OpenVAS is present in version 21.4.3.
Step 2: Checking GVMD Manager ... 
        OK: GVM Manager (gvmd) is present in version 21.4.4.
Step 3: Checking Certificates ... 
        OK: GVM client certificate is valid and present as /var/lib/gvm/CA/clientcert.pem.
        OK: Your GVM certificate infrastructure passed validation.
Step 4: Checking data ... 
        OK: SCAP data found in /var/lib/gvm/scap-data.
        OK: CERT data found in /var/lib/gvm/cert-data.
Step 5: Checking Postgresql DB and user ... 
        Starting postgresql service
        OK: Postgresql version and default port are OK.
 gvmd      | _gvm     | UTF8     | en_US.UTF-8 | en_US.UTF-8 | 
        ERROR: No users found. You need to create at least one user to log in.
        FIX: create a user by running 'sudo runuser -u _gvm -- gvmd --create-user=<name> --password=<password>'

 ERROR: Your GVM-21.4.2 installation is not yet complete!

Please follow the instructions marked with FIX above and run this
script again.

If I run the fix, I have no result

└─$ sudo runuser -u _gvm -- gvmd --create-user=admin  --password=admin

Kali version

PRETTY_NAME="Kali GNU/Linux Rolling"
NAME="Kali GNU/Linux"

If sudo runuser -u _gvm -- gvmd --create-user=admin --password=admin doesn’t return the output User created. something has gone wrong. Please take a look at the /var/log/gvm/gvmd.log file for further hints.



Thank you for your help here are the error lines following an execution of the order

md main: MESSAGE: 2021-11-02 12:38.43 utc: 1221: Greenbone Vulnerability Manager version 21.4.4 (DB revision 242)
md manage: WARNING: 2021-11-02 12:38.43 utc: 1221: Failed to open lock file ‘/ run / gvm / gvm-checking’: No such file or directory
md main: CRITICAL: 2021-11-02 12:38.43 utc: 1221: gvmd: Error trying to get checking lock

This problem might to be originating from an issue in the Kali packages according to 0007433: GVM is not installed - Kali Linux Bug Tracker :

FTR the postrgresql packages come from Debian Testing and the packages required for gvmd did not migrate at the same time in Debian Testing so in Kali too.

and should have been solved in Kali with:

I will update the gvmd package for postgresql version 14 to fix this

I have updated the package. Please update your system.
The fixed versions are:

  • gvmd version 21.4.4-0kali2
  • postgresql-common version 231

You may need to upgrade the postgresql clusters to version 14 (see “/usr/share/doc/postgresql-common/README.Debian.gz”, section “Default clusters and upgrading” for details)

1 Like

Thanks! Problem solved!

1 Like