Error 404 downloading the openvas-scanner sources

I’m getting error 404 while trying downloading the openvas-scanner sources, Building 22.4 from Source


curl -f -L$OPENVAS_SCANNER_VERSION.tar.gz -o $SOURCE_DIR/openvas-scanner-$OPENVAS_SCANNER_VERSION.tar.gz
curl -f -L$OPENVAS_SCANNER_VERSION/openvas-scanner-$OPENVAS_SCANNER_VERSION.tar.gz.asc -o $SOURCE_DIR/openvas-scanner-$OPENVAS_SCANNER_VERSION.tar.gz.asc

Please help me, how can I fix this issue.

1 Like

Hi @TMB and welcome to the forum :slight_smile:

It looks like the contents of the $GVM_VERSION variable wasn’t set. In the documentation, when you see “export” as something you are entering on the command line- that means it’s information (in this case the version number) that you are sending to the script. Then the scripts use that same information to download the version that you had entered, or pass the information along to other variables. If this step was missed at any point (you’ll need to do it more than once following the order exactly to the documentation) you can have things not working or missing/incomplete.

It’s also best to keep that part in one terminal session because if you open a second terminal it will not contain that information, since “export” isn’t permanent. What I usually do if I’ve missed something is go back to the very start of the documentation and try it again (or start fresh).


Hi @DeeAnn Thanks for replying.
I faced this issue just after started new ssh session to continue the build. All last steps were done in previous direct system logon. I was not enable to copy pass the command, that is why I switchted to ssh session. I will back to system logon and test again.

1 Like

Issue fixed right now. I juste followed these steps :
Thanks @DeeAnn

1- export GVM_VERSION=22.4.1
2- export GVM_LIBS_VERSION=22.4.4
3- export OPENVAS_SMB_VERSION=22.4.0

4- curl -f -L$OPENVAS_SMB_VERSION.tar.gz -o $SOURCE_DIR/openvas-smb-$OPENVAS_SMB_VERSION.tar.gz

5- curl -f -L$OPENVAS_SMB_VERSION/openvas-smb-$OPENVAS_SMB_VERSION.tar.gz.asc -o $SOURCE_DIR/openvas-smb-$OPENVAS_SMB_VERSION.tar.gz.asc


You’re welcome and I’m glad to hear that it worked :slight_smile:

1 Like