End-of-life Scan Engine

Hi all,

my reports for the last week all show a Severity 10 “Report outdated / end-of-life Scan Engine / Environment (local)”. I tried to set up an override as described in https://docs.greenbone.net/GSM-Manual/gos-21.04/en/reports.html#creating-an-override, but it seems to have no effect at all, so I think I probably misunderstand the settings:

Can someone tell me what I’m doing wrong?

The detection results are

Installed GVM Libraries (gvm-libs) version: 21.4.2
Latest available GVM Libraries (gvm-libs) version: 21.4.3

The installation is from the Atomic repo that currently offers no updates for the installed libs:

dnf update gvm-libs

Last metadata expiration check: 1:54:27 ago on Thu 25 Nov 2021 08:17:18 AM CET.
Dependencies resolved.
Nothing to do.



GVM versions

gsad: Greenbone Security Assistant 21.4.2
gvmd: Greenbone Vulnerability Manager 21.4.3
openvas-scanner: OpenVAS 21.4.2
gvm-libs: gvm-libs 21.4.2


Operating system: CentOS Linux release 8.5.2111
Kernel: Linux greenbone 4.18.0-348.2.1.el8_5.x86_64 #1 SMP Tue Nov 16 14:42:35 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
Installation method / source: dnf / http://updates.atomicorp.com/channels/mirrorlist/atomic/centos-$releasever-$basearch

Hi @MWV :grinning:

a suggestion from our Documentation Team is that you may need to enable overrides in the results as described here: 11 Reports and Vulnerability Management — Greenbone Security Manager (GSM) 21.04.9 documentation

Please let us know how it goes, thank you!

1 Like

Doh. I totally missed that. So overrides can change only how reports are displayed, not how they are generated, is that correct?

Sorry, I still don’t get it. I have the override from the image above, and in a task config, I have ‘Apply Overrides’ set to yes like this for example:

The report for this scan still shows the Severity 10 “Report outdated / end-of-life Scan Engine / Environment (local)” warning for every scanned target, unless I use the filter settings in the web frontend like DeeAnn said.

The docs for task configuration say “Overrides can be directly applied when adding the results to the asset database”. Does that not mean the results would be changed so they should be visible without an additional filter setting?

Hi @MWV ,
Did you figured out a solution for that issue ?
I am facing the same issue

Kind of. I configured filters now that use the overrides and set them as defaults for me in the web interface, so reports don’t show the stuff I don’t need to see. You can do that in “My settings”. It works like

  • Configure the override
  • Configure a filter of the appropriate type (e.g. Report) that uses the override
  • Set the filter in “My settings” as default for the type you used in the filter settings

I have no idea if that’s the correct way to do it, but it works for me :slight_smile: