Empty CSV Results

Hello everyone, this is my first time here so I hope to express my problem properly:

OS - Debian 10.2

I can’t download scan reports with format CSV Results, they are always empty (0 bytes).
When i download them, there are only these headers in the file:

IP,Hostname,Port,Port Protocol,CVSS,Severity,Solution Type,NVT Name,Summary,Specific Result,NVT OID,CVEs,Task ID,Task Name,Timestamp,Result ID,Impact,Solution,Affected Software/OS,Vulnerability Insight,Vulnerability Detection Method,Product Detection Result,BIDs,CERTs,Other References

Currently I have tried the download from gvm-cli and manually in the web interface GSA, but i do not get what i expect. The most strange thing is that CSV Hosts format works properly, so I really don’t know what could be happening. In addition, all the other formats work fine too.

I have modifyed too the timeout from gvm-tools in order to check if this was the problem, but nothing.
I have checked this topic too (among others), but the answer hasn’t solved the problem: Gvm-cli command dowload empty report

Unfortunately, gsad, gvmd, openvas and ospd-openvas logs do not show what it’s heppening.

To give more information about the gvm-cli executed intruction:
gvm-cli --config /opt/gvm/.config/gvm-tools.conf socket --xml “<get_reports report_id=”…" format_id="…" details=“1” ignore_pagination=“1” levels=“hmlg” min_qod=“0” />"

Sorry If something is not clear at all.
I really have been a lot of days looking for an answer but i haven’t been able to fix it.

Could you help me, please?

Thanks for your attention and time.

I’m closing this issue as a duplicate of the following topic below. Please follow-up there if you have further questions around this topic: