Couldn't initialize the plugin scheduler

GVM versions

gsa: None
gvm: gvmd-8.0
openvas-scanner: openvas-scanner-6.0
gvm-libs: gvm-libs-10.0


Operating system: Arch Linux
Kernel: 5.2.13-arch1-1-ARCH
Installation method / source: pacman

Hello everyone,

I am getting the following messages in the openvassd logs:

sd   main:MESSAGE:2019-09-10 21h10.47 utc:108604: openvassd 6.0.1 started
sd   main:MESSAGE:2019-09-10 21h22.53 utc:109067: The NVT with oid has no category assigned. This is considered a fatal error, since the NVTI Cache structure stored in Redis is out dated or corrupted.
sd   main:MESSAGE:2019-09-10 21h22.53 utc:109067: Couldn't initialize the plugin scheduler

Does anyone know how to fix the Redis cache issue?

Thank you in advance.

Hi @victor.sanchez,

This issue should be solved with a redis flush.

redis-cli -s /path/to/redis.sock FLUSHALL
1 Like

Hello @jjnicola

I tried that command yesterday. However, it didn’t work.

I think my problem is related with a timeout received (due to local bandwith limitations) while executing the following command:

$ greenbone-nvt-sync --wget

Somehow some NVTs where not downloaded/updated and thus, the database became corrupted.

I’ll keep you informed on my progress.

Thanks again.

Dear all,

Unfortunately, after several attempts (including the one posted by @jjnicola) I could not manage to get the Redis DB to its previous state .

I created a fresh new virtual machine and reinstalled the packages.

Kind regards.

Just run Redis “in memory” only and not persistent written to HDD. You just need to set the file socket and that´s it.

Hello @Lukas,

I’m currently using the following command to start up Redis.

$ /usr/bin/redis-server /etc/redis.conf

Where redis.conf is the Redis configuration file containing the following lines (among others, as documented in the Greenbone docs).

port 0
unixsocket /tmp/redis.sock
unixsocketperm 700

I have also migrated the database gvmd.db, so I assume it is in fact persisting the data to that file.

The openvassd.conf file contains the line:

db_address = /tmp/redis.sock

How do I run Redis “in memory”?


Hi @victor.sanchez

the problem was that the NVT with oid was removed from the Greenbone community feed. Therefore, you don’t have the nvt available anymore, while you are trying to schedule the nvt to be launched from an outdated scan config.
Find the NVT in the scan config and disable it.
This is a special case, and it should not have happened.


I know this is an old post, but I was having this same issue, because there was a custom NVT OID that was still in my scan config but the nasl file was missing, so openvassd was core dumping every time it ran.

Would it be possible to disable this NVT via command line? If so, how?.

Thank you.