Container image failed to run in AWS ECS

Hello everyone,
I tried deploying a container image to aws ecs. I pushed the official image to ECR, created a task, but after running the task exited automatically with an exit code of 0. I also didn’t find logs to debug the issue.

Can anyone help me to solve the problem, please?

Thank you!

Can you give more details on how you started and where you pulled the container from? I ask, because the GB container implementation is multiple containers, but your question seems to imply there is only one container.

Hi. The image was pulled from here.
Then I performed the following steps:

  1. Tag the Docker image and push it to AWS ECR
  2. Create a Fargate cluster for ECS
  3. Create an ECS task definition for Greenbone OpenVAS
  4. Run the ECS task

Does your Docker provide you will full kernel right and root privileges ? Otherwise you can´t run the scanner on restricted instances.

Hi man,
First, I am very grateful to you for your work. Maybe you could help me with my problem?
I have deployed your image with single GB container which I take from here. It deployed perfectly on my local machine as well as on AWS ECS. But unfortunately after a while I started getting this error:

sql_open: PQerrorMessage (conn): connection to server on socket “/var/run/postgresql/.s.PGSQL.5432” failed: FATAL: remaining connection slots are reserved for non-replication superuser connections

Maybe you have a solution to this problem?
Thanks in advance!

To get this solved the docker container in question would need to be updated to include the latest version 22.5.4 of gvmd (released yesterday) to include the following fix:


@vashmichael tag 22.4.20, pushed yesterday as latest, is using the 22.5.4 version of gvmd and should resolve this problem.

@cfi Thanks!

1 Like

Thank you guys! I really appreciate your work! @immauss @cfi