Compose file has errors

Even the Compose file has errors. If I follow the instructions on a fresh Ubuntu 20.04/22.04 install with all prerequisites I cannot even get past the docker compose. This goes for 21.4 and 22.4.

potatohead@Greenbone2:~/greenbone-community-container$ docker-compose -f $DOWNLOAD_DIR/docker-compose.yml -p greenbone-community-edition pull
ERROR: The Compose file '/home/paul/greenbone-community-container/docker-compose.yml' is invalid because:
Unsupported config option for services: 'gpg-data'
Unsupported config option for volumes: 'gpg_data_vol'

1 Like

Not sure what’s wrong here. Do you have docker-compose >= 1.27.0 installed?

I encountered the same error when trying to set up Community Containers 21.4 two days ago. I made sure that docker-compose is up to date. Using an old docker-compose file from 2-3 weeks ago worked flawlessly.

I’ll check that after my vacation.



I am sorry but I can’t reproduce your issue. My environment is:

> cat /etc/os-release 
PRETTY_NAME="Ubuntu 22.04.1 LTS"

> docker --version                                                                         
Docker version 20.10.12, build 20.10.12-0ubuntu4

> docker-compose --version                                                                 
docker-compose version 1.29.2, build unknown

With a clean docker setup (no 21.4 containers, volumes and images) my steps have been

export DOWNLOAD_DIR=$HOME/greenbone-community-container && mkdir -p $DOWNLOAD_DIR
cd $DOWNLOAD_DIR && curl -f -L -o docker-compose.yml
docker-compose -f $DOWNLOAD_DIR/docker-compose.yml -p greenbone-community-edition pull
docker-compose -f $DOWNLOAD_DIR/docker-compose.yml -p greenbone-community-edition up -d
1 Like

I’ve extracted the issue from Latest docker (22.4) worked great last week, now is suddenly unstable and broken into a new topic because both issues are unrelated.

1 Like

Same problem, with a new install on OpenSuSE 15.4; it appears that a more common version of docker-compose is 1.25.1!.

Is there any chance of patching the .yml for a more common v1.25?

You can easily update docker-compose with pip. we are relying on some features of this version.


Unfortunately, an upgrade breaks all sort of other stuff with dependencies.

Any chance of a “stable” version that will run on less-than-current systems?


Of course we could downgrade our requirements to a lower docker-compose version but this would again break some other things. Requiring this specific version is of course by intention to fix some nasty issues with the startup.

Btw. with Python applications like docker-compose it is very very easy to use them without having to install them system or even user wide.

python3 -m venv docker-compose-env
source docker-compose-env/bin/activate
python3 -m pip install docker-compose

and you will get an up to date docker-compose version in a separated virtual Python environment.

1 Like