Community feed URL redirects to, nvt-sync fails

Hello, when running greenbone-nvt-sync it fails to wget the community nvt feed and reports a 301 Moved permanently. Going to the url in the browser just redirects to the main page. Is there an outage with the community feed? Thanks.

Output of trying to sync below:

1 Like

I have a same issue, too.
It seems that has some trouble but looks fine. It works for me with in /etc/hosts for now.

Do not use this it´s a test system for a new bigger and faster greenbone community feed services and NOT updated, maintained yet (!).

The updated community feed will be “” (!).

1 Like

The only updated feed is with f[quote=“Ai0, post:1, topic:4887”]
nvt feed and reports a 301 Moved

Do not use HTTP use rsync with greenbone-nvt-update or our community edition.

1 Like

So, the Feed and the Feed-update process is and was OK :wink:

1 Like

Same thing here now and this is a real dealbreaker for me… We cannot download the rsync feed due to a complex proxy environment that only allows htt but no rsync. Is there currently any source for an up-to-date feed available over HTTP?

Start refreshing NVTs...
Setting http_proxy and https_proxy environment variables
Syncing NVTs using wget
--2020-04-09 22:10:38--
Connecting to connected.
Proxy request sent, awaiting response... 301 Moved Permanently
Location: [following]
--2020-04-09 22:10:38--
Reusing existing connection to
Proxy request sent, awaiting response... 301 Moved Permanently
Location: [following]
--2020-04-09 22:10:38--
Connecting to connected.
Proxy request sent, awaiting response... 200 OK
Length: 97000 (95K) [text/html]
Saving to: '/tmp/greenbone-nvt-sync.ozDpiF3jd2/openvas-feed-2020-04-09-267.tar.bz2'

100%[========================================================================================================================================================================>] 97,000      --.-K/s   in 0.04s

2020-04-09 22:10:38 (2.21 MB/s) - '/tmp/greenbone-nvt-sync.ozDpiF3jd2/openvas-feed-2020-04-09-267.tar.bz2' saved [97000/97000]

bzip2: (stdin) is not a bzip2 file.
tar: Child returned status 2
tar: Error is not recoverable: exiting now

@_OR and @Lukas - The openvas sync script forces http/https rather than rsync. It says rsync is not recommended for the initial sync. Falling back on http. By default when installing, you can’t choose rsync. The http endpoint is still failing.

I am facing a similar issue with my community setup. Based on the discussion on this thread I now understand what the problem is. Is there a valid fix that I can use please?

I also have the same problem now.

Just use RSYNC, that`s it. Now the new rsync server is much bigger then the old infrastructure. Same rule no NAT one rsync session per source IP. If your proxy does not support this and you run it in a cooperate environment, you might wanna look for the commercial Geenbone offerings.

I am sorry but I am new to rsync. Can you provide actual steps on how to use rsync to get the nvt feed please?

greenbone-nvt-sync --rsync


wow that worked…thanks much

1 Like

I have tried both sync and rsync commands and am not being able to connect to the greenbone server. The subdomain and domain of greenbone cannot be pinged. My firewall has allowed all ICMP, UDP and TCP protocols but its still not working. Here are the following errors:

Please read the other posts here:

1 Like