Can't update Greenbone

Dear Mr./Ms,

I’m trying to update Greenbone but without success.
I’ve been reading about the updates and I realized that this problem is not knew but unfortunately I could solve yet.
My greenbone is Version 22.4.0 (community edition).
I run
without success.
I get “…|:80… failed: Connection timed out”

After that,
I add the line in /etc/hosts:
and run:
sudo greenbone-nvt-sync --verbose --rsync
sudo greenbone-certdata-sync --verbose --rsync
sudo greenbone-scapdata-sync --verbose --rsync
And it seems that worked, but when I check the separator “administrator”->“Feed status” in the Greenbone page, I notice that the updates were not succeeded. The NVTs, CVEs, etc, keep outdated.

I run
/usr/sbin/openvasmd --update --verbose --progress
and I get “Updating NVT cache… \ done.”

I run:
/etc/init.d/openvas-manager restart
/etc/init.d/openvas-scanner restart

reboot the machine and now I check the NVTs are updated (the status = current) but just a few minutes because after that the status return to “21 days old” again. The SCAP (CVEs and CPEs), CERT and GVMD_DATA keep outdated (in the separator “administrator”->“Feed status” in the Greenbone page).

What should I do to update Greenbone?

Thank you for your help.

Best regards

Hi @Fabio1 and welcome to the forum :slight_smile:

How did you install the Community Edition (Docker container, Linux repository, etc.) and what operating system are you using?

Hello @Fabio1

My greenbone is Version 22.4.0 (community edition).

If you just want to update the feed, why don’t you just update the feed containers?.


Hello DeeAnn,

thank you for your response.
I install using your script. I used this commands:
"curl -f -O && chmod u+x

sudo ./ 22.4"

What installation process do you recommend?

My Linux is ubuntu server 20.04.4 LTS.

Thank you for your response.

Hello Victor.sanchez,

thank you for your response.

I will try doing this.
Thank you.

Hello DeeAnn,

To be able to scan the network I had to install also the openvas (sudo apt install openvas).
Is it the right procedure or did I something wrong?

Thank you.

@Fabio1 please follow a single guide and don’t mix things. From you first message I am really sure you didn’t run an up to date version of our software and instead used OpenVAS 9 which is very very very very very old. The feed scripts from this version wont work anymore because they use outdated and shut down servers.