Can't start Notus-Scanner

Hi all
I’m building the Greenbone Community Edition from source with Ubuntu. It seems everything worked fine so far without any errors. but for some reasons Notus-Scanner can’t start.
I don’t get any error with “sudo systemctl start notus-scanner”, neither with “enable”. but if i enter “sudo systemctl status notus-scanner” i get following:

notus-scanner.service - Notus Scanner
Loaded: loaded (/etc/systemd/system/notus-scanner.service; enabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Mon 2024-01-22 09:47:08 UTC; 30s ago
Docs: GitHub - greenbone/notus-scanner: Notus is a vulnerability scanner for creating results from local security checks
Process: 482178 ExecStart=/usr/local/bin/notus-scanner --foreground --products-directory /var/lib/notus/products --log-file /var/log/gvm/notus-scanner.log (code=exi>
Main PID: 482178 (code=exited, status=1/FAILURE)
CPU: 305ms

If i check the ospd-openvas.log it says: “OpenVAS Scanner failed to load VTs. Command ‘[‘openvas’, ‘–update-vt-info’]’ returned non-zero exit status 1”

Installing Notus-Scanner step by step didn’t gave me any error, so it seems it was installed successfully.

Any idea what this problem could cause?
Thanks for your help


could you please take a look at /var/log/gvm/notus-scanner.log, /var/log/gvm/ospd-openvas.log and /var/log/gvm/openvas.log for possible errors?


Sorry for my late response. i just installed everything new with containers and now it works.