Can't install OpenVAS on Kali Linux


first of all: I am not the best in english, but I’ll try my best. I am looking since hours for a solution, …
I installed openvas and I am able to go to the WEB GUI. But I can’t do


“Command not found”. So I looked up google, found this: - I followed the thread, downloaded all packages and unzipped it. But it’s not working to install even the first one “openvas-libraries”! After I try it with “make” and “make install” or even configure, it is always coming the same problem:

… checking for GLIB … configure: error: “glib >= 2.6.0 not found”
Makefile:28: openvas-libraries.tmpl: No such file or directory
make: *** [Makefil:37:openvas-libraries.tmpl] Error 1 <

I can’t go on … can someone please give me a hint how to do it, but with easy instructions.

Lisa XX

1 Like


the issue you did mention is for Ubuntu 9.04 and therefore really old and outdated.

I guess you are using Ubuntu packages for 18.04 (Bionic). In that case you are using GVM 9 aka. OpenVAS 9 (GVM-9 (stable, initial release 2017-03-07)) which includes openvas-scanner 5.1.3. In that case the openvas-nvt-sync script got renamed to greenbone-nvt-sync. You can take a look at for the files contained in the openvas-scanner Ubuntu package.


Hey bricks,

thanks for your answer! Well, I am using Kali Linux and I read (what a know now because of your important information) a very old tutorial. The greenbone-nvt-sync command is working, I guess…
But it comes out this:

rsync: failed to connect to ( Connection refused (111)
rsync: failed to connect to (2a01:130:2000:127::d1): Network is unreachable (101)
rsync error: error in socket IO (code 10) at clientserver.c(125) [Receiver=3.1.2]

Maybe my ip is blocked because I tried it twice? I am not really sure, if I am synced, how can I know that? I can see some stats and informations …

Is there a serious guide for OpenVas under Kali?



have you tried the tutorials section where various articles for OpenVAS on Kali exists:

If the articles are missing info for e.g. the “greenbone-nvt-sync” you could get in contact with the author of those tutorials to get the info included.

1 Like

Hi cfi,

thank you for your answer. I tried to finish up the setup. The sync worked. But when I know go to the gui, in the top comes:

SecInfo Database Missing

What to do?
I looked up the whole tutorials you sent, I will contact the author.

Use greenbone-certdata-sync and greenbone-scapdata-sync.

1 Like

Maybe will help too

1 Like