Can't delete unused alerts

Hi everyone,

pretty much what subject says: I can create and use custom alerts, but I can’t delete them anymore, even when they are not used by anything. The trashcan is greyed out with a tooltip “Alert is still in use”, even though no task is attached to it and the detail view for the alert has no entries in the “Tasks using this Alert” field.

I tried restarting all services relevant to greenbone, same result. I also restarted the machine, also same result.

Does anybody have an idea what I’m doing wrong or what else I could try?

GVM versions

gsad: Greenbone Security Assistant 21.04.0
gvmd: Greenbone Vulnerability Manager 21.4.0
openvas-scanner: OpenVAS 21.4.0
gvm-libs: 21.4.0


Operating system: CentOS Linux release 8.3.2011
Kernel: Linux 4.18.0-240.22.1.el8_3.x86_64 #1 SMP Thu Apr 8 19:01:30 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
**Installation method / source:**Atomic yum repo:
OSPd-openvas.x86_64 @atomic
atomic-heimdal-libs.x86_64 7.5.0-8.el8 @atomic
atomic-heimdal-runtime.x86_64 7.5.0-8.el8 @atomic
greenbone-security-assistant.x86_64 @atomic
gvm.noarch @atomic
gvm-libs.x86_64 @atomic
gvmd.x86_64 @atomic
openvas-scanner.x86_64 @atomic
openvas-smb.x86_64 @atomic

Did you deleted all tasks that uses that alert ?
The pure existence of a task with a alert attached even without results or scans will trigger this behavior.

1 Like

I did not delete the task, but I switched it from using alert X to using alert Y. After that (and mentioned restart attempts including a complete reboot) I still can’t delete alert X.

To answer my own question, in case somebody has the same problem:

Delete per click on the trashcan next to the alert was not possible because the trashcan was greyed out even for unused alerts. Filtering the alerts and “Apply to filtered…” did work.

1 Like