Can't delete erroneous report

Hello Greenbone Community, I hope you’re all doing well.

Yesterday, I manually ran a NVT feed sync, blissfully unaware that some scheduled scans were 15 minutes away. Of course, those scans failed due to the VT list being empty while the new NVTs were being loaded into the scanner, generating four reports with an error status.

Unfortunately, I seem to be unable to delete those reports. Clicking on the delete icon in GSA waits for roughly 20 seconds, then shows this:


I have already tried to solve the problem using gvm-tools scripting, yielding the same results.

The log from /var/log/gvm/gvmd.log shows the following:

event report:MESSAGE:2022-11-18 10h28.15 CET:819967: Report TaskNameHere - 2022-11-17T16:47:55Z (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx) could not be deleted by admin

Do you have any tips regarding this issue? It’s be greatly appreciated.

1 Like

I’m gonna bump this issue.

Since my post, I have migrated to GVM 22.4 and this issue still persists, even with non-erroneous reports. I just can’t delete reports at all, neither via the web interface nor GMP.

Is anyone else encountering this issue?

I can confirm that this is still a problem, even with the official community containers. I don’t always see the Internal Error message when I click the X to delete a report, usually it just does nothing. Sometimes if I wait or reload the page it will work but I can’t find any rhyme or reason for the error.

Hello @TreAtW

As far as I remember Greenbone follows a set of steps before creating the report. For instance:

Create configuration → Create target → Create task → Create report.

According to the snapshot that you have included, some of the tasks associated with the reports are in “Interrupted” state.

Have you tried to stop/delete these tasks before removing the reports associated with them?

Kind regards,


Hello victor, thanks for your response.

Since my initial report here I have migrated from GVM 21.4 to 22.4, on which I didn’t generate any erronous reports anymore. Back on 21.4, even after stopping the corresponding tasks, deleting the reports was not possible. Now on 22.4, deleting any report is not possible, even if they are not erroneous and the task has finished gracefully.

I have the same problem. The reports cannot be deleted at all. I get the same error message in the log as @TreAtW
Does anyone have an idea how to track down the error?

Same here now.

event report:MESSAGE:2023-10-17 09h21.49 CEST:24652: Report <name> - 2023-10-17T07:16:53Z (66b1a085-ffd3-467b-a644-6791e5ad2327) could not be deleted by <admin>

and not just this one, looks like no report can be deleted anymore.

Update, so other people who were affected get notified too: It seems like this issue has been fixed.