Can't create scan config

I know this is a recurring problem but I have found no solution so far.
Error message: Failed to find config ‘d21f6c81-2b88-4ac1-b7b4-a2a9f2ad4663’
OS: Kali Linux 2024.1
OpenVAS version: 22.4.1
GVMD_DATA and nvt syncs up to date.

This is a new installation and has never worked. Any help appreciated.


Hi, first of all check the feed status page if all feeds have been loaded. Afterwards check the scan configs list page if any scan configurations are available on that page.

Thanks for the hint about the feeds. SCAP and CERT were too old. All are now current.
The Scan config page just says “Scan Configs 0 of 0”
I still cannot create a scan config :frowning:

1 Like

But the gvmd data feed is up to date?

NVT, SCAP, CERT and GVMD_DATA are all “Current” now.
Still can’t create scan_configs


first of all please check if there are any errors in the gvmd log file at /var/log/gvm/gvmd.log.

Thanks. Checking /var/log/gvm/gvmd.log for errors…
Nothing useful I think:
Several of these as OpenVAS is starting:
md manage: INFO:2024-03-18 16h19.31 UTC:6980: osp_scanner_feed_version: No feed version available yet. OSPd OpenVAS is still starting

When I tried to create a config:
event config:MESSAGE:2024-03-18 16h20.55 UTC:7817: Config could not be created by El_Tel

El_Tel user has roles Admin and Monitor

I have noticed that under /var/lib/gvm/data-objects/gvmd there are directories:
22.04 22.09 22.9
While gvmd is version (23.3.0-0kali2)
and Greenbone Security assistand is Version 22.9.1

At this point I would completely re-install from a fresh version of Kali Linux following the official Kali Linux install instructions. You said something was wrong from the start and you have not mentioned any customization you have made. :person_shrugging:

Well I’d originally followed the install instructions. I had hit a few problems with the version of postgresql which I’d solved. Maybe that was something to do with it.

But running the install again went straight through and now seems to have fixed it.


1 Like