Cannot create a task with an ospd_scanner Error: Scanner and config mismatched types

Hello everyone
I installed GVM20.08 on Debian 10. After integrating an Osp Scanner (in my case ospd_nmap), I can’t create a task. i am getting this error.

Here are the components I used:
GVM Libraries 20.08
OpenVAS 20.08
OSPd 20.08
ospd-openvas 20.08
GVMD 20.08
GSAD 20.8

Since OSPD-Nmap (on Github / Greenbone) requires [ospd> = 1.2, ospd <= 1.4], I had to create a virtual environment and install ospd1.3


i had the same problem with my remote sensor. After changing the scanner type on the command line it worked for me.

gvmd --modify-scanner=<scanner_uid> --scanner-type=‘OSP-Sensor’
Scanner modified.

When you now check the scanner again with --get-scanners the type changed from OSP to OSP-Sensor and in the master GUI the scanner type changed from OSP-Scanner to “Greenbone Sensor”.
If you hit the “verify” button it will show “service unavailable” but thats a lie, it works now.

btw the remote sensor has been started with
/opt/gvm/bin/ospd-scanner/bin/python /opt/gvm/bin/ospd-scanner/bin/ospd-openvas --pid-file /opt/gvm/var/run/ --port 9390 --ca-file /opt/gvm/var/lib/gvm/CA/cacert.pem -c /opt/gvm/var/lib/gvm/CA/servercert.pem -k /opt/gvm/var/lib/gvm/private/CA/serverkey.pem --log-file /opt/gvm/var/log/gvm/ospd-scanner.log --lock-file-dir /opt/gvm/var/run/ospd/



1 Like