Authentication failed with gvm-cli


I am running GCE 4.2.24 and gvm-cli 1.4.1
I am trying to use gvm-cli from my PC to create a target :
gvm-cli ssh --log INFO --gmp-username cliuser --gmp-password clipassword --hostname --xml “<create_target>Suspect Host1.2.3.4</create_target>”

I am always getting “Authentication failed.” error
gvm-cli.log shows:
INFO:paramiko.transport:Connected (version 2.0, client OpenSSH_6.7p1)
INFO:paramiko.transport:Authentication (password) failed.

cliuser is defined as admin user and can connect through the web interface.

I found in documentation that GMP should be activated in the setup menu but don’t have such an option.
Am I missing something?

thanks for your help


you may need to set the ssh user and password to login at the virtual machine. Currently I don’t know if the SSH server is accessible from the outside nor the ssh username.

Also you should update to gvm-tools 2.0.0.beta1 for using username/password ssh authentication. See gvm-cli ssh --help for the --ssh switch details.


the GCE doesn’t provide the GMP/OMP API as described here:

This is probably also the reason why you can’t find how to enable/activate GMP within the setup menu.


3 posts were split to a new topic: How to use socketpath in gvm-cli