Authenticated Scans - invalid or empty private key


I am currently trying to setup an authenticated scan but when entering my private key - I am getting a message saying invalid or empty private key. I have tried generating a new private key from other articles I have read but nothing works. I need to be able to use a key based on my original puttygen generated private key as my public key is on all of our servers. I have tried conversions using multiple methods - generating openssh keys, changing the generation versions and other methods) but nothing works. I changed the type to ed25519 as mentioned in another article but this does not work either.

Do you have a standard method that works - to regenerate a private key from an existing private key - that will work in the Greenbone Openvas system. Nothing I have read so far has worked so I really need some help here.


From the docs:

SSH key pairs can be generated using the command ssh-keygen on Linux or puttygen.exe if using PuTTY on Microsoft Windows. To use an existing SSH key pair for authentication, the private key must be supplied when the credential is created. The private SSH key must be either in PEM or OpenSSH format. The key types Ed25519, ECDSA, RSA and DSA are supported.

1 Like