Unable to free up space or access SU

Good Day everyone,

I have been having an issue with our GSM 150 unit that has been sitting running for months on end with no management done to it since i started at my company and i have been tasked at getting it back up to proper care.

the issue i am having is when the unit boots i get an error message when i try to log in:

Welcome to the Greenbone OS
Transaction file corrupted.
The current transaction file will be deleted and a new one will be created.
Traceback (most recent call last):
File “/usr/bin/pyspatch”, line 11, in
load_entry_point(‘PySpatch==2.5’, ‘console_scripts’, ‘pyspatch’)()
File “/usr/lib/python3/dist-packages/pyspatch/init.py”, line 40, in cli_entry
return main(args)
File “/usr/lib/python3/dist-packages/pyspatch/init.py”, line 33, in main
ret = action(interface)
File “/usr/lib/python3/dist-packages/pyspatch/actions.py”, line 113, in call
if action(dialog):
File “/usr/lib/python3/dist-packages/pyspatch/dialogs.py”, line 161, in call
dialog.infobox(PT(self.text), title=PT(self.title))
File “/usr/lib/python3/dist-packages/dialog.py”, line 2687, in infobox
File “/usr/lib/python3/dist-packages/dialog.py”, line 1717, in _widget_with_no_output
code, output = self._perform(args, **kwargs)
File “/usr/lib/python3/dist-packages/dialog.py”, line 1501, in _perform
File “/usr/lib/python3/dist-packages/dialog.py”, line 1290, in _call_program
mode=“w”, prefix=“pythondialog.tmp”, delete=False)
File “/usr/lib/python3.5/tempfile.py”, line 679, in NamedTemporaryFile
prefix, suffix, dir, output_type = _sanitize_params(prefix, suffix, dir)
File “/usr/lib/python3.5/tempfile.py”, line 269, in _sanitize_params
dir = gettempdir()
File “/usr/lib/python3.5/tempfile.py”, line 435, in gettempdir
tempdir = _get_default_tempdir()
File “/usr/lib/python3.5/tempfile.py”, line 370, in _get_default_tempdir
FileNotFoundError: [Errno 2] No usable temporary directory found in [’/tmp’, ‘/var/tmp’, ‘/usr/tmp’, ‘/home/admin’]

one i try to log in again it lets me log in, however I have no superuser access and i have tried the GOS commands i found on another post but those result in admin not having permission to user su as root and we do not have the root login information.

am i stuck with this and just have to do a fresh setup on this unit as i cannot clear any used space at all as my current user level access.

Also, when the unit boots it says GOS 5 near the top, which i am assuming this version it is running is way behind the current supported of GOS 21. maybe i just do a clean install?


Hi @kylel and welcome to the forum :slight_smile:

Can you please send me a direct message with your contact information so Product Support can get in contact with you? Thanks!

Edit to add- you can also file a ticket for appliance support here:


hey @DeeAnn, I tried to DM you but it would not let me.

I tried troubleshooting some more yesterday and i added a external ssd and used the recovery shell to mount it as a added lvm partition and extended the existing sda3 lvm partition to it to get a total of 162gb over the 55GB it had, but upon reboot it wont recognize that change, had my fingers crossed but to no avail.

I will try submitting a ticket in the mean time

Thanks again

i have had some success in my trial and error issue.

I was trying to mount the wrong vgroup partition (or should i say mapper).

through the gsm install and recovery menu using the minimal shell i was able to mount the drive and remove a couple MB of spare files that were not needed. once i did this the system booted and i was able to log in and it went to the gsm menu.

now on to a new issue however. I enabled GMP service via the menu and set up a webadmin username and password, but when i tried to log in i got the same, GMP service is down, message. i went to reboot the unit via the menu and it just froze up and now i have to wait to get back in to the server room to hard reset the box.

i have made progress which is good. is there a way to backup and purge old data all at once with these units?

also the support page for some reason wont load at all.


Why don´t you just export your subscription / save your subscription key, do a flash upgrade and then reinstall the updated GOS 21.04.x? There is a factory reset option within the boot menu.
Just contact our support team and they are happy to help you with the fastest way to upgrade / fix your appliance!

Hi @kylel,

the support system had some downtime so if you want you can give it a try and I will also send you a DM (my guess is that the forum software prevents DMs from newer accounts but that’s something I’ll have to look into later).

@Lukas I don’t think they know the process yet as it looks like they were put in charge of a unit that someone else had sent up (and not much maintenance long the way), so they are learning it fresh.

thanks everyone, I got a email back from the support team lastnight (time difference i believe). yesterday i ended up just doing a clean install on the system, i took a screencap of the info page before hand with the license number because i doubt anyone here knows it or has a copy of it anymore.

I am hoping the support can help me get a new license using that number to import to the system. i had set it up without the license for not and updated with the community feed for now so i can get some stuff set up for now.

1 Like

Cool! It sounds like you’re on your way to getting it all going again. And yep, probably a time difference (we’re based in Germany).

yes, they just got back to me with the file to upload for my key. thanks for the help!

1 Like

Glad to hear it and you’re welcome!