[SOLVED] OpenVAS hangs at 1% on Kali Linux


I am using Kali linux 2018.2 as a VM in VirtualBox to scan a Metasploitable-VM for vulnerabilities.
My scans are running super slow. I used to scan only one IP (Metasploitable-VM) with the default “full and fast” definitions and it would take about 1-3 hours. (Task Wizard - Quick Scan)
With the newest version of OpenVas with all the updates:

When the Scan starts, I can retrace the comunication with wireshark. After 9072 pakets the scan stocks. The progress shows 1% and the CPU goes to nearly 100%.
My Kali-VM has 12GB Ram and 8 CPUs. So I don’t think that this is a problem of too few RAM. The CPU is a Core i7 4,2GHz. The free command shows 9.8GB of available RAM.
After a long time the scan continues und the CPU relaxes again…

I tried to scan a physical Cisco Router and I have the same trouble.
Anyone run into this before? Have any suggestions?

Thank you very much for help!

regards, Daniel

Same issue for me,

It is related to this thread https://community.greenbone.net/t/community-feed-unusable/132

We need to wait for a fix to be applied to the Kali libraries or go in and path and recompile yourself. I am not that brave yet.


1 Like

FYI kali repos have been updated with latest scanner :slight_smile:

1 Like

Daniel or GB: Can you confirm it is fixed for you?

Yes, now eyerything works well again! Thank you!

Hi Jan, working very well now, possibly faster than before.


Hi All,

Need help, facing the same problem with OpenVAS getting stuck at 1%.

This is now discussed in [SOLVED] Not able to scan a host via IP address or Domain and is much likely not related to the issue discussed here.

1 Like