Scan Results shows zeros, but task report lists all discovered vulnerabilities

I’ve been trying to get GVM running on Kali for training purposes, and every time I install the package it seems to work fine up until a task finishes and the overall task severity is N/A and the total count of scan results are all zero. But when I click into the actual task report, it shows all the discovered vulnerabilities, and each one shows it’s individual severity score correctly.

I’ve tried 2 different Kali installs (pre-built VM and ISO install) and installed openvas on both, and I’m getting the same result on both.
I’ve also tried syncing all 3 data feeds individually (all succeeded, SecInfo Dashboard looks good), and I even ran ‘openvasmd --rebuild’ which completed successfully, but I’m still getting the same results from new tasks. Yes, I even rebooted just in case that would make a difference.

Screenshots attached to show what I’m seeing (the scan target was Metasploitable 2 VM, so don’t worry it’s not a real host :slight_smile: )

Has anyone seen this before? Any suggestions?

GVM versions

gsa:7.0.3 (‘gsad --version’)
openvasmd:7.0.3 (‘openvasmd --version’)
openvas-scanner:5.1.3 (‘openvassd --version’)


Operating system:Kali Linux, based off Debian
Kernel:Linux kali 5.3.0-kali3-686-pae #1 SMP Debian 5.3.15-1kali1 (2019-12-09) i686 GNU/Linux (‘uname -a’)
Installation method / source:Kali meta-package and apt install openvas


it seems you are using old versions. Please update the versions:


Unfortunately that’s not an option as building GVM 11 has been giving me continuous errors at various steps (most recently for me it’s erroring out building the gvmd), so I’m sticking with pre-built packages and this appears to be the latest.

Everything else in my install is working fine, just not this summary line of scan results which is why I’m asking the question here to see if anyone has insight in the cause.

Maybe you have entered a filter in the Report view?
You’ll find the active filter in small script under the filter field.

Thanks for the suggestion Tino. This was a brand new install with no filtering or other customisation done on the reports or dashboard.

Then please get back to your package provider, we DO NOT support any 3rd party uncoordinated integrations here. Alternatively you can use our community edition.

1 Like

Thanks for the helpful response Lukas, my main question was if anyone has experienced the same problem with the code and not the packaging of the code, or has possible suggestions to investigate for the problem. As mentioned I did try the latest GCE and had multiple problems building it, so I think I’ll give up and stop recommending this software and the community forum.

Is far as I’m concerned, I’m not sure what exactly you mean, since the GCE doesn’t need to be built; the GCE is a virtual appliance with the latest release pre-built (so why would you have multiple problems building it?) for the community, which you would just need to download and run as a virtual machine.
You could probably use it directly as is for your teaching purposes.
You can download it on this page:
the currently latest version (link to the DL) being:
There is some learning curve for a complex software like this.
The search function of the forum also is helpful.
HTH, and good luck!


Apologies TheOneAndUs, I made an error, I meant GSE the source edition, so that it could be upgraded and the task reports kept from one version to the next. I did try the GCE VM once, but as it’s just the free version it doesn’t allow upgrades, and unless I’m wrong there’s no easy way to migrate old task reports to a new version of GCE as it’s a whole new installation.
Yes, I guess the GCE is good for short-term use, or for longer term use if you’re not so concerned about new releases of the software.

Yes, so this is kind of a problem for those (a) not buying a real thing with enterprise feed and update guaranties and (b) not using the prebuilt GCE.
There are so many distros with different configurations changing over time, so who could actually support all of them?
Not sure why your distro (kali you said) is lagging somewhat behind with their packaged version, but they seem to work on an update to the current version, if I read their bug tracker correctly.


While i never have seen the behavior of the first screenshot i can say that the behavior of the second screenshot was a bug in the manager code (See Php nvt 2018 error) which might be even responsible for the behavior on the first screenshot and which got fixed nearly one year ago with:

Kali seems to be shipping GVM-9 (based on the posted component versions) which has already reached its end-of-life (See GVM-9 (end-of-life, initial release 2017-03-07)), that’s probably the reason why Lukas has redirected you to the Kali maintainers to get a updated versions of GVM which should solve all known issues.


I found a workaround that worked at least once, so I’m replying back here to help future me and anyone else who searched for the same problem I had.

Rebuild the report cache seems to have worked:
openvasmd --optimize=rebuild-report-cache

I had first ran --optimize=update-report-cache but that didn’t make any difference, so rebuild did the trick.


Please note that it might be possible that this problem is originating from the previously mentioned outdated (and possible buggy) version shipped by Kali.

Updating to a newer version is strongly recommended which might already solve this in a more reliable way.