Scan config missing

how long for the feed data to update? i have installed the system this morning using the atomiccorp repo which has the binaries ready built for openvas and i am missing the scan configs even though the files are in the appropriate folders and there are no errors in the logs.

using this guide to build on centos 8 i ran in an issue described at post #48 to which i could not find an answer

I don’t have a clue about the status of the atomiccorp repo packages. Last time they have been really outdated and broken.

3 posts were merged into an existing topic: Full GVM-11 Build Guide for CentOS 8

For the records, there is an open issue about this topic at the Atomicorp github tracker:

i opened it today. i was wondering though if it could be something general that you might be able to help with

I guess their setup script isn’t setting the feed import owner correctly so that the scan configs and report formats can’t be imported and used.

i have tried to set the feed import owner to the uuid of the admin user but it did not work either

There is a report in the previously linked issue that the gvmd binary of the atomic repository is in a broken state and segfaulting:

This should be fixed first by the package maintainer.

@bricks @cfi speaking with atomic they say they took the below from the file
su - gvm -c “/usr/sbin/gvmd --modify-setting 78eceaec-3385-11ea-b237-28d24461215b --value $FEED_OWNER”

is that UUID correct for the setting or is it changing and if it does how to get the correct one?

This is the correct UUID and AFAIK doesn’t change (i have three different setups using the same UUID).

Note that the import of the scan config might still fail as the gvmd binary provided via the atomic repository seems to be segfaulting for at least one user: