Rsync: failed to connect to

Same issuse since September.
My NVTs are 26 days old, SCAP and CERT 42 days old and can’t update them.

Still getting:

rsync: failed to connect to ( Connection refused (111)
rsync: failed to connect to (2a01:130:2000:127::d1): Network is unreachable (101)
rsync error: error in socket IO (code 10) at clientserver.c(125) [Receiver=3.1.2]

Tried two different VMs in two different envs and it’s the same error.

If I try to download manually from
dl. greenbone. net / community-nvt-feed-current.tar.bz2
getting “Connection refused” error also.

I’m using:
OpenVAS Scanner 6.0.0
Greenbone Security Assistant 8.0.0
Greenbone Vulnerability Manager 8.0.0
on Ubuntu 18

Hi PioTrek,

please take a look at this:



Hi @_OR

I am upgrading from gvm 11 to the latest gvm 20.08 , after building the openvas 20.08 and setting up the redis-server , I executed “greenbone-nvt-sync” .
I get the following error .
rsync: failed to connect to ( Connection timed out (110)
rsync: failed to connect to (2a01:130:2000:127::d1): Network is unreachable (101)
rsync error: error in socket IO (code 10) at clientserver.c(127) [Receiver=3.1.3]

Why is it trying to connect to the old server ?
How can this be solved ?


Maybe there are left-over from your old system. I would suggest to format your system and do a blank re-installation if you can´t debug this via shell.


Thanks a lot @Lukas
There was indeed a nvt-sync routine which had the old URL in /sbin path, just modified the URL with new one there ,solved my issue .
Thanks again .


Hi can you help me , i have the same error !
im using GVM 11 on ubuntu 20.04

sync: failed to connect to ( Connection refused (111)
rsync: failed to connect to (2a0e:6b40:20:106:20c:29ff:fe67:cbb5): Network is unreachable (101)
rsync error: error in socket IO (code 10) at clientserver.c(127) [Receiver=3.1.3]

Check that no active TCP session exists between your internet address and the back end.

rsync: failed to connect to (2a0e:6b40:20:106:20c:29ff:fe67:cbb5): Network is unreachable (101)

Fix your routing first … Network is unreachable shows your are not connected to the whole (IPv6) Internet.

Then check with netcat on the RSYNC port, if this is not working your device is messing the connection up.
is should look like:

# nc 873
@RSYNCD: 31.0
Greenbone community feed server -
This service is hosted by Greenbone Networks -

All transactions are logged.

If you have any questions, please use the Greenbone community portal.
See for details.

By using this service you agree to our terms and conditions.


hi lukas
this is output
gvm@openvas:~$ netcat -v 873
-netcat: connect to port 873 (tcp) failed: Connection refused

Do you have any devices between your GVM installation and the internet ?

If so please remove them. It looks like a messed up connectivity at the moment.

1 Like

Itried ’ $ netcat -v 873’
on another server ubuntu connected to the intenet and i got thse same output :
netcat: connect to port 873 (tcp) failed: Connection time out
netcat: connect to port 873 (tcp) failed: Network is unreachable

And how do you connect the Internet? That might be your problem if you cant commect to the feed service

I did a GVM update to newer version and it worked. What version are you using?

1 Like

GVM 11
ubuntu 20.04

Try the following:

sudo apt-get update
sudo apt-get install gvm
sudo gvm-feed-update

1 Like

I had the same issue at another network and the troubleshooting tells me that maybe the firewall is blocking the RSYNC port TCP 873. I will ask for the port to be open and let you know if that fixes the problem. Maybe you can try that too.

1 Like

@pablo Can you please describe your troubleshooting steps with the firewall issue? Even with a brand new installation of Kali and following all the steps you mentioned in the previous comment, I am still receiving the same errors. I am not on my company firewall, just connected to my home router (which does not have have IPv6 capability). Thanks for your help!

Hi Sara, I managed to fix it by first updating the OS, the one I am using is Kali 2020-4.
After that you should check that the Postgres port is the default one. By opening all internet ports I guess something was being blocked the update went through.

1 Like

Hi Gangambika,
may you please describe how to change nvt feeds URL path manually ? I have openvas9 and can not update feeds with greenbone-nvt-sync
returns :
Resolving (…, 2a01:130:2000:127::d1
Connecting to (||:80… connected.
HTTP request sent, awaiting response… 502 Connection reset by peer
2020-12-12 08:41:35 ERROR 502: Connection reset by peer.

Please note that while it is possible to update the feed URL manually it is strongly discouraged to run such an outdated and end-of-life version of OpenVAS (now called GVM). Instead is is recommended to update to a still supported / recent version of GVM already using the new URLs (available since 6+ months).

OpenVAS-9 has already reached it’s end-of-life in September 2019 with GVM-10 and GVM-11 following by the end of this year (2020). This also means that the feed will be open for changes which are only available since GVM-20.08 and the feed is getting more and more incompatible with your outdated OpenVAS-9 and might even stop to work completely.


Hey! The same problem! How to correctly update version? Didnt find any docs