Problem with port list

hi, I ask you for help, I have a python script that scans with openvas, given an ip, and returns a report.
Until a few weeks ago the script worked without problems , but now it does not and I get an error like :
“an error occurred response error 404. Failed to find port_list '4a717fe-57d2-11e1-9a26-406186ea4fc5w”…
has the id for the ports changed or is there some other type of problem?
Thanks in advance to who will answer me.


did you check if you actually have port lists? Maybe you use some distro packages and these packages got updated from 21.4 to 22.4 which requires a new feed sync. Just guessing here.

Just for your info, the UUIDs of our data objects (report formats, scan configs, port lists) from the feed never change.

1 Like

I reinstalled openvas a few days ago , it seems strange to me that everything is not updated , however would there be a command to give to the terminal to update the feeds ?

Hi @coch,

You can use this command on terminal to update Feeds assuming that you’re using openvas on Kali Linux: # sudo gvm-feed-update


ok , i used that command but still doesn’t work …
other solutions?

i used the openvas console and saw that in configurations>portlist , there is no portlist … i updated the feeds , including SCAP, CERT , GVMD_DATA , but no port list appeared … please can you help me I don’t know what to do anymore

Take a look at

If you are on Kali you need to use sudo -u _gvm instead of sudo -u gvm.

1 Like

the portlist xml files are there, I ran the command to get the GVMD_DATA feeds but nothing changed … I tried to rebuild but I get this error “failed to rebuild gvmd data: feed owner not set or invalid while rebuildings configs” …
what else can i do ?

You can read the next troubleshooting article especially the part about the feed import owner, search in the forum for feed import owner, read the 20.08 release announcement or take a look at the install instructions of gvmd.

1 Like

i tried to do everything described in the links he sent me but nothing happened … i also tried to uninstall and reinstall it , but nothing , the portlists are always absent … i’m desperate , i don’t know what i should do anymore

If you get this error you don’t have a feed import owner set correctly. But nevertheless please check the gvmd.log and also the ospd-openvas.log files for further errors. At the moment it seems installations on Kali are broken due to a bug with the GPG feed validation. Kali ospd-openvas not staring with MQTT broker errors - #2 by bricks

1 Like

so it’s a problem that depends on openvas and not on me? However from what I’ve seen it’s not just the portlists but just all the GVMD_DATA feeds which, although present in the installation folders, seem to not be seen …

It could be possible that your are facing an issue with the installation on Kali. But it could be also something else.

Therefore please check the /var/lib/gvm/gvmd.log and /var/lib/gvm/ospd-openvas.log files for additional errors.

1 Like

they don’t say anything relevant, is it possible that I’m the only imbecile who has an unsolvable problem?

I tried them all, even uninstalling and reinstalling but nothing changed … on the web there don’t seem to be any similar problems … I’m the only asshole it seems as always

Step by step instructions:

  • check if there are scap data xml files in /var/lib/gvm/scap-data

Run greenbone-feed-sync --type SCAP if no files are available

  • check if there are cert data xml files in /var/lib/gvm/cert-data

Run greenbone-feed-sync --type CERT if no files are available

  • check if there are port list xml files in /var/lib/gvm/data-objects/gvmd/22.04/port-lists
  • check if there are scan config xml files in /var/lib/gvm/data-objects/gvmd/22.04/scan-configs

Run greenbone-feed-sync --type GVMD_DATA if no files are available

  • check if there are nasl files in /var/lib/openvas/plugins

Run greenbone-nvt-sync if no files are available

If all things are ok until now, check the web UI if the data files have been loaded.

Take a look at Administration → Feed Status if the feed loading process is still in progress. If it is in progress please be patient and wait for some time (even some hours).

  • Check SecInfo → NVTs

If you don’t have VTs ospd-openvas hasn’t loaded them yet and/or gvmd could request the VT metadata from ospd-openvas. Check the ospd-openvas.log for Loading VTs. Scans will be [requested|queued] until VTs are loaded. This may take a few minutes, please wait …. The gvmd.log should contain a OSP service has different VT status (version X) from database (version (Y), Z VTs). Starting update … message.

  • Check SecInfo → CVEs
  • Check SecInfo → CERT-Bund Advisories
  • Check SecInfo → DFN-Cert Advisories

If these aren’t available gvmd hasn’t loaded them (completely) yet. You need to take a look at the gvmd.log file if update_scap: Updating data from feed is mentioned. If not run sudo -u _gvm gvmd --rebuild-scap.

  • Check Configuration → Port Lists
  • Check Configuration → Scan Configs

These files are also loaded by gvmd. Your gvmd log should contain messages like Port list All IANA assigned TCP (33d0cd82-57c6-11e1-8ed1-406186ea4fc5) has been created by admin and Scan config Full and fast (daba56c8-73ec-11df-a475-002264764cea) has been created by admin. If not run sudo -u _gvm gvmd --rebuild-gvmd-data=all.

If all these things are still not suffice there must be another error. In that case you need to take a deep look for errors in all systemd journal outputs and the logs in /var/log/gvm.

1 Like

i managed to make GVMD_DATA and thus the portlists visible to the GUI …
I ran these commands:

sudo runuser -u _gvm – gvmd --get-users --verbose
sudo runuser -u _gvm – gvmd --modify-setting 78eceaec-3385-11ea-b237-28d24461215b --value
Where is the long guid string you just got from the command above

I still have a problem though … I have a python scan script that runs a vulnerability scan of my pc using gvm.
The problem is that when I run the script, the terminal still tells me it can’t find the portlist.

I think it’s due to permissions?
I should have if I’m not mistaken the symbol of a pair of glasses in the lines of the portlists instead I have nothing …

I’m facing the same problem.
Have you found any solution?

Thanks! and good luck

Got it!

  1. sudo runuser -u _gvm -- gvmd --get-users --verbose (notice this should be two - characters between _gvm and gvmd, not a long dash). This should return the users (mine gave only admin), and their uid

  2. sudo runuser -u _gvm -- gvmd --modify-setting 78eceaec-3385-11ea-b237-28d24461215b --value <uid> Where <uid> is the long guid string you just got from the command above, for the user you are running openvas under)