Permissions openvassd.sock

Some basic information:

GVM versions



**Operating system:Ubuntu 18.04

I build and installed the source code edtion of openvas some days ago. During this installation I installed Openvassd under root permissions and the other deamons (gsad, gvmd) under a specif user. The problem i encounter is that gsad does not have permissions to access the openvassd.sock socket. When i change this with chmod, it will work as expected.

I’m trying to figure out where i can set this setting permanent so that i don’t have to manually edit the permissions when a reboot is done.

Final note: The problem is not in the redis.sock, where a config file is available, but in the /var/run/openvassd.sock

From openvassd --help

  --listen-owner=<string>          Owner of the unix socket
  --listen-group=<string>          Group of the unix socket
  --listen-mode=<string>           File mode of the unix socket

and gsad doesn’t connect to openvassd. It communicates with gvmd.

1 Like

I’ve allready tried the --listen-group command but it seems not to work. When i use this and reboot the machine and restart openvassd, gsad, gvmd the problem still exists

Furthermore in my main post i wrote about the connection between gsad and openvassd, but i meant between gvmd and openvassd.

To be sure, you have to actually start openvassd with this option. If a process is already running to won’t change the socket permissions. The socket permissions are only set on creation of the socket.


Yea I understand that, I stopped openvassd before i tried it with this option.

Ohh… wait i’m stupid. I thought the --listen-group was used to change a setting for openvassd and that you needed to run openvassd after that. Now I used the --listen-group as a starting parameter and it worked.

Thanks for your help

1 Like

Yes as I wrote it doesn’t change the permission. It sets the permission when being started.

You are welcome.

1 Like