Only NVT's Sync - No SCAP or CERT Data

Running greenbone-nvt-sync correctly updates the NVT’s and states “Current” in Feed Status, however both the SCAP and CERT entries remain outdated. This was installed 3 days ago, so currently NVT’s are Current, and the others state “3 Days Old”

I run greenbone-scapdata-sync and greenbone-certdata-sync, yet it does not update these definition feeds. I tail -f gvmd.log, gsad.log and openvassd.log at the same time as running these, and not 1 single line of log data gets written out, so it is as if these commands do absolutely nothing. There are no errors, the RSYNC operation completes with only downloading a single file, called “timestamp”, but nothing else happens, no processes spawn under gvmd, no logs are written, nothing.

GVM versions

gsa: 8.0.0
gvm: 8.0.0
openvas-scanner: 6.0.0


Operating system: CentOS 7.7
Kernel: 3.10.0-1062.9.1.el7.x86_64
Installation method / source: Atomic Repo

Try now it works …

1 Like

Looks good, SCAP data is now syncing, usually takes ~1hour but I assume this is all OK now. (Before it wasnt even spawning the gvmd process to sync SCAP, it just rsync’d the timestamp and stopped).

Was this a problem with the SCAP feed? Or is it just that the SCAP data on the feed doesnt get pushed out until its X days old?

In my side I tried NVT first then Cert , and last will be SCAP

if Im facing any issue I will add
–curl – verbose

Ok, thankyou for the info anyway :slight_smile:

1 Like

Please note that those are outdated versions of GVM-10 not matching the versions of the current GVM-10 (old stable, initial release 2019-04-05) and which are affected by various known bugs.