Missing GVM_DATA in GSA

FYI, it appears that there was a recent GVMD_DATA update. My feed status jumped from 41 days old to 4 this morning. This is a good time to recheck your feed status.


Can confirm, that the GVMD_DATA “version” timestamp presented in feed.xml was changed.

Seems to be solved.

Thanks @unretired for his point.

1 Like

Thats right the timestamp changed to “20210917T0825”.
But in my case it changed by running this command manually: su -c “rsync -vrP rsync://feed.community.greenbone.net:/data-objects/gvmd/ /var/lib/gvm/data-objects/gvmd” gvm

By running the following command nothing happens.
su -c “greenbone-feed-sync --type GVMD_DATA” gvm

And i have still no data in my GSA…


share please the output of the sync su -c “greenbone-feed-sync --type GVMD_DATA” gvm
what is really happend?

1 Like


Using the GVM-Docker from Secure-Compliance, I do have exactly the same problem, GVMD_DATA are locally present, but not shown on WebUI

bash-5.1# ls -l /var/lib/gvm/data-objects/gvmd/21.04/port_lists
total 372
-rw-r–r-- 1 gvm gvm 125164 Jan 1 1970 all-iana-assigned-tcp-33d0cd82-57c6-11e1-8ed1-406186ea4fc5.xml
-rw-r–r-- 1 gvm gvm 240545 Jan 1 1970 all-iana-assigned-tcp-and-udp-4a4717fe-57d2-11e1-9a26-406186ea4fc5.xml
-rw-r–r-- 1 gvm gvm 10268 Jan 1 1970 all-tcp-and-nmap-top-100-udp-730ef368-57e2-11e1-a90f-406186ea4fc5.xml

this is for ports, but same problem for report formats and policies.
It looks like GSA is searching for GVMD_DATA at the wrong place.
I found another GVMD with similar structure at /var/lib/gvm/gvmd and tried to copy data into it but it doesn’t work… i didn’t find a way to verify (like an environment variable) where GSA is supposed to find GVMD_DATA…

I have the same problem.
Тhis happened after the transition from postgresql 13 to postgresql 14.
GVM_DATA are no visible in GSA.doc (197.5 KB)

Hi @svg64,

I have faced that issue and solved it. Follow this link upgrade Postgresql 13 to 14 and see step by step how to solve.


1 Like

I applied the steps suggested in the link. Everything works perfectly. Thanks.