GVM 20.08 Missing Report Formats and Scan Configs

Installed GVM 20.08 on Debian and scans work fine but missing the Full Ultimate and Very deep scans.
Also Report formats don’t include CSV host and only CSV results and 5 more.(GVM 11 had more report Formats).
I understand that the scan config and Report formats come from the feeds.

How can I import a Report Format (tried exporting from GVM 11 and importing to 20.08 but no luck needs validation). I really need the CSV hosts export as it includes the list of host with OS in CSV.
Why the scan configs are missing the Ultimate and very deep.

Used the below commands to update feeds:
greenbone-feed-sync --type GVMD_DATA
greenbone-feed-sync --type SCAP
greenbone-feed-sync --type CERT

GVM versions

gsad: 20.08
gvmd: 20.08
openvas-scanner: 20.08


Operating system: Debian Buster 10.5
Kernel: 4.19
Installation method / source: Source

I’m having the same issues. I just upgraded from gvm 9.0 to 20.08 and I have fewer Port List and Scan config options that I used to.

If there’s no way to get this from GVMD_DATA, maybe someone still running an older version could export it and post it here?

I’m particularly interested on Port Lists, Scan Configs and Report Formats.

Have You added the user as import feed owner?


gvmd --modify-setting 78eceaec-3385-11ea-b237-28d24461215b --value USER_UUID

Replace USER_UUID with uuid. You can get user uuid with the command:

gvmd --get-users --verbose

After You have done that, try importing. It should work now.

Also be sure that ospd-openvas socket is either in /var/run/ospd/ospd.sock or if You have it in another location, have modified the path in gvmd.

This is done with:

gvmd --modify-scanner=SCANNER_UUID --scanner-host=/directory/to/ospd.sock

Replace SCANNER_UUID with UUID. You can get UUID of OpenVAS Default scanner with

gvmd --get-scanners

If it still doesn’t work, check if You have NVT-s synced.
To sync, run:


Just saying, that all of this is documented in github and in release notes. Read the manual :smiley:
Sorry for bad formatting.

1 Like


Yeah, when I ran those, it did create a few scan configs, report formats, port lists.

But it didn’t create all options it used to have. For example, for scan configs I don’t have Full and very deep ultimate. For port list, I miss some options too.

It seems that those are not included anymore. I don’t have them aswell, but I could export them from an older version. I can give You the files if needed.

You may have noticed that fewer scan configurations, port lists and report formats are supported in GVM 20.08 in comparison to previous versions.

The reasons are the following:

  • The scan configurations, port lists and report formats are now delivered via the feed and are therefore faster to maintain.
  • Some scan configurations, port lists and report formats are no longer maintained in our Greenbone Community Feed.
  • During a migration, the old scan configurations, port lists and report formats are not removed but are retained. However, they may no longer function completely or not at all.
  • We think about adding a warning for users about incompatible scan configurations, port lists and report formats in the future.

Yes I did same issue.

Thank you for clarifying.
Will the current scan configs in GVM 20.08 provide same results as deep scan configs in GVM 11.

We had Full Deep Ultimate which provided good results, while we only have normal scans with GVM 20.08.

You can import old scan configurations, but they may not work.

Hi, is there a possibility that you will add csv host as a supported report format?
I try import that format from GCE 6.0.7 but after activated it ist’t posibble to use it.

@mark0w can you send a link to the docs for this?
Hard to find.

I’m having issues with python-gvm. It’s unable to load the report_format_ids

This worked for me! Thank you

Hi! It is all documented here:

What do the logs say? It is hard to conclude what the problem is without logs.


After I run this command:
report = gmp.get_report(report_id=task_report_id, details=True, report_format_id=ReportFormatType.CSV_RESULTS)

Python sends me back this:
<get_reports_response status="404" status_text="Failed to find report format 'c1645568-627a-11e3-a660-406186ea4fc5'"/>