GVM-10 with LDAP

Has anyone tried testing LDAP authentication to the web interface GVM ver. 10?

We have a config working perfectly with LDAP authentication on OpenVAS 9, however as I’m sure everyone has pointed out by now, there have been quite a few changes to GVM 10.

I am 100% sure our LDAP host, Auth. DN., and CA certificate are valid. Just wondering if anyone has gotten LDAP working yet and what they did.

I’ll even take suggestions where ldap authentication logs might be located so I can see where ours is failing.

I have been testing LDAP authentication without success so far as well.

Are you facing the same issue or any different one?

No, I have not gotten an error like that one in the other topic.

Our LDAP settings get saved with no issue, and I can’t find anything obvious in our logs.

When we create a user there is no extra field for LDAP auth. like there is on GVM-9 so I’m not sure if it is working, maybe that extra field just got removed?

I confirm I am also facing LDAP authentication issues after upgrading GVM from 9 to 10.
I am using installed from source on Debian stretch using the latest tags (not master branches).

Before upgrading, LDAP authentication worked nice, but since the upgrade I am unable to use it.

I authenticate users against Active Directory, all the domain controllers provide the same wildcard certificate for the domain name.

I was also missing the LDAP authentication option, but I solved the problem like described here : https://github.com/greenbone/gsa/issues/1339#issuecomment-496534888


Do you have any more information on how you got this working?

Do we have to create the dialog.js file under that path?

I installed GVM from source, pulled from GitHub : https://github.com/greenbone/gsa

After cloning gsa sources into /usr/local/src/gsa, I checked out tag v8.0.0, then downloaded dialog.js from master branch over the file in v8.0.0 branch and reinstalled gsa (see file INSTALL.md for instructions).