Full GVM-11 Build Guide for CentOS 8

In that case you don’t have installed the scanner component.

1 Like

do you find solution for this

My weak scan was normal, but today I found it failed and the log showed the following error:

lib osp:WARNING:2020-08-25 04h40.06 utc:10073: osp_get_vts_version: element VTS missing.
md manage:WARNING:2020-08-25 04h40.06 utc:10073: manage_update_nvt_cache_osp: failed to get scanner_version

This may occur when the scanner (ospd-openvas) is (still) loading the feed data (the vulnerability tests).

1 Like

2 posts were split to a new topic: Scan config missing

what about the issue on compiling openvas. as i said the issue is in post 48 in the other thread

Could you give me the link? I can’t find the post manually.

I’m not sure but i think we should close this topic as the 80 posts are related to so many different issues makes it just huge and hard to follow.

I guess it would be the best that any upcoming problem should be discussed in separate topics so that such a new topic can be marked as solved with a provided solution.

@bricks Any opinion about that?

1 Like

it is because of the quotation marks. when you copy/paste it puts the wrong one and linux is not reading the lib folder

See the information in the build guuide about adding the path to /etc/profile. You missed a step.

1 Like

From the command:
echo “/opt/heimdal/lib” > /etc/ld.so.conf.d/heimdal.conf

Remove the " from file or edit the file /etc/ld.so.conf.d/heimdal.conf e remove the "


1 Like

HI guys,

I followed the guide and faced the below issue after sync nvt data last night. It looks like the number of plugs is incomplete (only 27929 plugins) and I try to type “greenbone-nvt-sync” or add “–rsync/–curl/–wget” to sync again this morning. It is not worked and no response.

[gvm@BPZA006VRA ~]$ greenbone-nvt-sync
[gvm@BPZA006VRA ~]$ greenbone-nvt-sync --rsync
[gvm@BPZA006VRA ~]$ greenbone-nvt-sync --curl
[gvm@BPZA006VRA ~]$ greenbone-nvt-sync --wget
[gvm@BPZA006VRA ~]$ find /opt/gvm/var/lib/openvas/plugins | wc -l
[gvm@BPZA006VRA ~]$

Best Regards,

Please update your installation, Feed-Server & Sync-Script changed months ago. End of this month all old server will be switched off.


I followed this “full GVM-11 Build Guide for Centos 8” to build new GVM11 on Centos 8 server yesterday. All the installation is the same as this guide.

Its seems to that command “greenbone-nvt-sync” is Interrupted while running sync data. Can I sync the nvt-data from feed.community.greenbone.net manually? Or would you please provide the solution to solve this issue, thank you very much.

Best Regards,

Hi @Lukas

I find the solution and it can sync nvt data . I need to delete lock file in:


Best Regards,

1 Like

Please note such lock files should be on tmpfs, you need to check you installation and clean-scripts.

1 Like

Hi @Lukas,

I have synced the nvt-data and installed completely, thanks.

But I face the other issue about web console that the feed Status of NVT is missing.

I check the NVTs of SecInfo is 39895 and the number of plugs is 63120, verify scanner is OK.

I am very new to Linux and GVM.
Would you please provide the some suggestion for me? thank you very much^^

Hi *,

unfortunately this topic got a sinkhole for so many different issues with many of them not even related to the initial build guide.

As this topic has grown too much (90+ postings) which makes it nearly impossible to follow and to mark / follow solutions for the different issues i’m closing it to avoid that it is getting even more messy.


  • create a new topic for each new / or (in this topic) already unanswered / not solved GVM related problems and make sure to provide all necessary environment information (e.g. GVM component versions, environment, …) like asked in the topic template
  • use the “Flag topic” functionality of this topic if there are any problems with this build guide itself (e.g. something needs to be update in the first topic) so that the moderation team can take care of it

Thanks for your understanding.