External access to GSA web interface / IP

Wish I had found this earlier. This is exactly what I required to get it running.

For /etc/default/greenbone-security-assistant

I set the IP to my server’s IP. Save and then do the following
systemctl daemon-reload followed by the services
service openvas-scanner restart
service openvas-manager restart
service greenbone-security-assistant restart

/lib/systemd/system/greenbone-security-assistant.service, set --listen and --mlisten to and add --allow-header-host yourserver.yourcompany.com

setting the host as the FQDN and save. Run the following:
systemctl daemon-reload
systemctl greenbone-security-assistant

This worked for me. It’s been 10 years since I really used any Unix and I’m very rusty. Happy I got this going. Hopefully it helps. I also setup the A record, which was something I initially forgot.

I am using 5.2.0-kali2-amd64.

1 Like