Client Web Portal Timeout

Hey Guys,

Trying to get some answers on typical issues that I’m sure users run into, but having trouble finding the answers.

I’m attempting to increase the timeout for a client through the web portal.

I found the below link which detailed using the gsad command to accomplish this, but I get an output that doesn’t make sense and doesn’t seem to change the setting.

gsad --timeout=1440

Can anyone point me to the proper file/location to change this for my users?

Thank you!


This setting is still the right place to tweak. How gsad is started and where you have to adjust this settings highly depends on your used distribution.

This messages have nothing to do with your problem and are just warnings

1 Like

Hey Bricks,

After a few days of testing this setting doesn’t seem to make any noticeable change. With a setting of 1440 for the timeout switch it should stay up after login for 24 hours.

You mention that it matters “where you have to adjust this setting” based on your distro; would that include attempting to make this change?

I’m specifically on Kali but if you could point me in a direction to find this information myself that would be great.

Thank you again for your time!


as you’re running Kali a good starting point could be to ask at how to configure such settings for the Kali Distro (maybe there are also some existing threads available there).

There are also a few tutorials for a Kali based OpenVAS/GVM setup available which i’m linking below, if those are not containing the related information you could also ask the maintainer of those pages to get the information included for easier access to it.

Hey Guys,

It seems like the gsad --timeout command doesn’t actually make the change to the greenbone-security-assistant.service file.

Found the resolution to this by hardcoding the timeout switch directly into /lib/systemd/system/greenbone-security-assistant.service file.

ExecStart=/usr/sbin/gsad --foreground --listen= --port=443 --listen= --mport=9390 --allow-header-host IP or Hostname --timeout=1440

This line will allow you to access GSM GUI via https and over whichever port you set (here it’s 443), as well as setting the GUI user timeout to 24 hours.



Sorry I thought it would be obvious to change the script/config where gsad is started from in your distribution. In most cases this is the systemd service file nowadays.


In my system, the config file was under /etc/systemd/system/gsad.service

Modified the setting

from: ExecStart=/opt/gvm/sbin/gsad --drop-privileges=gvm

to: ExecStart=/opt/gvm/sbin/gsad --timeout=1440 --drop-privileges=gvm

1 Like

I Found the solution of this problem and increased the session time.

Under /usr/lib/systemd/system/greenbone-security-assistant.service file

add " --timeout=1440 " (without quotes) after --port=

after adding it should look like this:
ExecStart=/usr/sbin/gsad --listen= --port=9392 --timeout=1440

restart your web client and after logging in your session time would be increased for 24 hrs

Best Regards

1 Like