Can't create a scan config (failed to find config)

I can not create a scan config.
Failed to find config ‘085569ce-73ed-11df-83c3-002264764cea’

I have split that question from the build guide it was posted because it was completely unrelated to the build guide itself.

Is there any answer? @lucidlynx

You need to give us some more details about the used version of GVM and its components. Also please add a statement about how you did build/install our software.

Hey @bricks,

Here is more info:

OS - Ubuntu 20.04
GVM - 20.08

I used this howto:
*but with 20.08version

Everything is ok, but when I try to create a new task, scan config is missing.

Also when I try to create a new scan config, there is an error:
Failed to find config ‘daba56c8-73ec-11df-a475-002264764cea’

Any ideas what to do?


You need to sync the new object data and to set a feed owner. Also gvmd needs to be aware of all NVTs by syncing them with ospd-openvas.

See details at


A post was split to a new topic: Failed to connect to ( Connection refused (111)

Could you please just mention the commands we need to choose to solve this issue. i am new to GVM and do not understand your suggestions.

1 Like

Information on both commands to set the feed import owner and new object data (GVMD_DATA) are available in the already linked topic:

I did all the steps with no error. but still the Scan configs is deactive. and I still face the error:
Failed to find config ‘085569ce-73ed-11df-83c3-002264764cea’

root@kali:/home/kali# sudo runuser -u _gvm – greenbone-nvt-sync
root@kali:/home/kali# sudo runuser -u _gvm – gvmd --get-scanners
08b69003-5fc2-4037-a479-93b440211c73 OpenVAS /var/run/ospd/ospd.sock 0 OpenVAS Default
6acd0832-df90-11e4-b9d5-28d24461215b CVE 0 CVE
root@kali:/home/kali# sudo runuser -u _gvm – gvmd --get-users --verbose
admin dabd2710-aebd-4048-a8c7-460b60e5fa93
root@kali:/home/kali# sudo runuser -u _gvm – gvmd --modify-setting 78eceaec-3385-11ea-b237-28d24461215b --value dabd2710-aebd-4048-a8c7-460b60e5fa93

root@kali:/home/kali# greenbone-feed-sync --type GVMD_DATA
Greenbone community feed server -
This service is hosted by Greenbone Networks -

All transactions are logged.

If you have any questions, please use the Greenbone community portal.
See for details.

By using this service you agree to our terms and conditions.

Only one sync per time, otherwise the source ip will be temporarily blocked.

receiving incremental file list
13 100% 12.70kB/s 0:00:00 (xfr#1, to-chk=0/1)

sent 43 bytes received 114 bytes 1.18 bytes/sec
total size is 13 speedup is 0.08

sudo runuser -u _gvm – gvmd --modify-scanner=08b69003-5fc2-4037-a479-93b440211c73 --scanner-host=/directory/to/ospd.sock
Scanner modified.

Note that the ospd-scanner service needs to be running correctly (depends on your Linux Distro but checking should be possible with something like service ospd-openvas status and should have loaded all VTs before the scan config can be imported.

Please check if this is really required on your Linux distribution.

Also note that it seems you’re using the Kali packages of GVM, please check the readme / notes of that packages for further help / information how the setup is done there so that the scan config are correctly migrated.

Hi I had the same problem, although in a different environment (I’m currently using a GVM container) and managed to solve it with your steps, but there is a small mistake (or at least the correction below worked for me):
Instead of:
sudo runuser -u _gvm – gvmd --modify-setting 78eceaec-3385-11ea-b237-28d24461215b --value dabd2710-aebd-4048-a8c7-460b60e5fa93
please try:
sudo runuser -u _gvm – gvmd --modify-scanner 78eceaec-3385-11ea-b237-28d24461215b --value dabd2710-aebd-4048-a8c7-460b60e5fa93
(I used a slightly different command, for docker…, but the concept should be that one above)

I have the same problem and I have not been able to solve it… help me please…

Please try as follows. It worked for me, with different commands since using docker, honestly I don’t even know why. Just one of many tries…

sudo runuser -u _gvm -- greenbone-nvt-sync
sudo runuser -u _gvm -- gvmd --get-scanners
(note your scanner id)
sudo runuser -u _gvm -- gvmd --get-users --verbose
(note your user id)
sudo runuser -u _gvm -- gvmd --modify-scanner [scanner id] --value [user id]

1 Like

hi , @filo I have the same problem… HOw I can get the (scannerid | userid) info.
Thx in advanced

1 Like

Hi @quisutd3us
Actually what I meant is:
sudo runuser -u _gvm – gvmd --get-scanners
should give you as output the list of your scanners; the first column, if I remember well, should be the scanner ID.
Then, equivalently, entering:
sudo runuser -u _gvm – gvmd --get-users --verbose
should give you the list of your users (most likely you’re using “admin”), including their IDs.
Finally, entering:
sudo runuser -u _gvm – gvmd --modify-scanner [scanner id] --value [user id]
should do the trick.
Again, please consider that I’m not an expert, and this is only what solved my own problem, which, although showing the same error message, maybe had different “root causes”…
As said before, I just started from some instructions reported above in the thread, making a change because something was telling me that probably my user was not owner or was not “connected to” my scanner.

I hope this helps…


this one helped to me. Exactly these 3 commands. Thank you.



I am also facing the same issue of failed to find scan config in ubuntu. I tried the 3 commands but somehow I am not getting the scanner id in my terminal.Can you please help me what am I doing wrong.

Hi @BAK, most likely the problem Is in the single dash - before gvmd: It should be double, --, like before get-scanners, buy with a space before gvmd

Thanks for your reply, I tried what you said but it gave nothing as an output.