After Login "The request contained an unknown or invalid Host header"

Right now come on this thread is clearly not solved its not a timeout issue and it shouldnt be the inclusion of an external / internal ip address as youve already provided as both the sources. I am frankly not happy with this I recall having the same or similar issues with nessus but cant recall what the solution was. Obviously this is different and I am much appreciative of all your hard work here but it is simply a basic requirement that you can access the web ui over the net!! We should not be changing the systemd files in order to do this. I have ammended the config script pointed to here more /etc/openvas/openvassd.conf
However all to no avail. I am informed that the headers provided by my browser are the reason for this message:

The request contained an unknown or invalid Host header. If you are trying to access GSA via its hostname or a proxy, make sure GSA is set up to allow it.

I find that also equally unlikely I have here the ammended systemd file:
/lib/systemd/system/greenbone-security-assistant.service Modified
Description=Greenbone Security Assistant
Documentation=man:gsad(8) 4

ExecStart=/usr/sbin/gsad --foreground --listen= --port=9392 --mlisten=
–mport=9390 --allow-header-host myip --timeout 1440

We shouldnt need --allow-header-host or --timeout for a start it should suffice for the mlisten and listen options to be

So Id appreciate some frank answers here. My company is waiting for its audit and I cant do it without access to the web ui.

I do ofcourse appreciate this is a free service. Many thanks.

I am running Kali linux as a VM on a Windows server. There must be a reason this isnt working. Unfortunately I am a small outfit and our software is not updated and runs exclusively on Windows XP so you can see the reason why I need the audit done.

Thanks, Simon