Scans doesn't want to move from 0%

hello everyone, in gvmd.log i’ve this error:
osp_scanner_feed_version: failed to get scanner_feed_version. OSPd OpenVAS is still starting

After much time the scan is yet at 0% via web interface i’ve this problem:
An internal error occurred while performing an action. It is unclear whether the resource has been affected. Diagnostics: Failure to receive response from manager daemon.

How can i solve? Thanks a lot

Hello beppelucertole,

Are you using containers or have you built from source? Are all feeds completely synced and up to date? The error message looks like there are problems with either GVM, OpenVAS, or both. Maybe restarting it is all it needs.

Hello TreAtW you’re great. All feeds are up to date and restart doesn’t change anything…

Are you using containers, have you built from source or are you using a third-party package? What version are your feeds at? Do your logfiles contain anything additional after the scan failed?

Feed are updated today, logfiles contains nothing because i have to interrupt scan when this message appears to me An internal error occurred while performing an action. It is unclear whether the resource has been affected. Diagnostics: Failure to receive response from manager daemon. I haven’t build from source, i’ve downloaded it from apt … repository, i don’t use containers. And now, after changing password for admin with the command sudo runuser -u _gvm -- gvmd --user=admin --new-password=yournewpassord can’t login

Installing from 3rd party repositories with apt is not recommended. It’s outside of the control of the Greenbone team and community, sometimes dependencies are missing and in general it’s pretty… janky. With gvm-check-setup you can run an automated check whether or not all dependencies are met and all services are properly installed.

I strongly recommend using containers. You can find the easy setup guide here: Greenbone Community Containers 22.4.

1 Like

with gvm-check-setup is all ok, i’ll see soon containers. Do you know how can login now?.. An other question, can i upgrade to latest version of openvas? How?

You should be able to login with the new password that you set. If not, try to use your old password or change it another time.

Upgrading to the latest version is pretty complicated when using the Greenbone Community Edition from a 3rd party repo. You’ll probably encounter many obstacles that are very hard to overcome, especially for beginners. Again, I recommend using containers as a) they are available in the latest version contrary to 3rd party repos and b) it’s way easier to upgrade.

1 Like

Nothing…, i’ll consider containers way. Now, i have to login i tried to change password and login with old password, it doesn’t work…

If this command doesn’t work it is very likely that your setup is broken. The cause is probably a wrong postgres db. You need to look at /var/log/gvm/gvmd.log for possible errors.

1 Like

To remediate this issue you need to look at the /var/log/gvm/ospd-openvas.log file. It may just be the case that the feed data isn’t loaded completely yet.

1 Like

I wouldn’t say it isn’t recommended. It’s just no developer is using these packages, we aren’t involved in the packaging and don’t get notified about changes in the packages. As a result we might not be able to help with specific issues.

1 Like

Well, I think it’s safe to say that it should not be preferred over community containers or even building from source. It’s one of the most error-prone and inconsistent installation methods and it’s more difficult to troubleshoot as an outsider. To correct my statement: “Personally I can’t recommend installing from 3rd party repositories with apt”.

1 Like

thanks a lot to both of you. You advice containers or build from source?

I can recommend using containers over building from source.

1 Like

I’ve a file .ova in which is installed openVAS, i’ve done some scans first of this problem. Now i’ve reload VM from zero without any configuration by me, it yet not works scans doesn’t move from 0%. In log file it seems normal. I’ve update every feeds an other time. I don’t know where i can find information about that, an other location of log files? Deamons are running and in their log files there aren’t any relevant information. This i see, some other advice and help? Thanks

When you visit the feed status page (Administration → Feed Status), what does it show?
Does the file /var/log/gvm/ospd-openvas.log exist and if yes, what does it contain?

Now it works, i’ve reinstalled all from zero


Great, I’m happy to hear that everything is working now :slight_smile: