Python-gvm (API) Socket.Timeout-Configuration GVMD-Version 20.08

Hello everyone,

i am using gvmd version 20.08.
I’ve been looking for an answer to the question for 2 hours, but unfortunately I can’t find one. I use python-gvm to download hundreds of reports (XML) and evaluate them centrally. Sometimes the reports contain the check of several 100 systems.

Due to the size of the reports, i get a socket timeout. Unfortunately I can’t find the option to extend the socket timeout (I know the option for GVM-Tools, but GVM-Tools can’t be used in this project).

I would be glad if you could tell me where to configure the socket timeout.

best regards


I think I solved the problem.

I thought the entire time that I have to use a configuration file, like it is used with services like GVMD or with the CLI tool gvm-tools. It was also not possible to find a solution in the API-documentation, which is why I put all my hopes in the configuration file.

The information IS in the API-documentation, but for whatever reason not in the main-documentation. You can find the timeout-option info in the “readthedocs”-startguide for the API under “Connections”. The timeout-option have to be configured for the specific class-object, the default timeout-time is 60 seconds and too short for some operations. I set the parameter to 3600 (1 hour), I don’t get timeouts anymore.

Main-documentation: Tech Doc Portal
readthedocs-startguide, section Connection: Connections — python-gvm 21.11.1.dev1 documentation


Hi @FlorianBc,

Thank you for letting us know that you found it (and where) and that it seems to be working.

(edit to add as just an FYI, we’re in the 21.4 series now, so if you run into any issues it might be worth upgrading)